Comodo Firewall Installer not working with Windows 8.1 (compatibility problem)

At this time the latest comodo firewall from the comodo.com (version 6.2) can’t be installed under Windows 8.1 RTM (TechNet), because Windows 8.1 says there are compatibility issues.

Compatibility Mode does not do the trick, nether with Windows 8 nor Windows 7.
This is even more strange, because version 6.2 works with Windows 7.

I recently upgraded from Windows 7 Professional SP1 to Windows 8 Professional to Windows 8.1 Professional.

At the moment the most recent version of CIS (6.2) does not support Windows 8.1. However, I expect this support to be added soon, perhaps in the next release, which shouldn’t be too far away.

For now then I will move this post to a section of the forum where you may receive some advice which may help you to get CIS working on Windows 8.1. I seem to remember that there is a workaround, but cannot remember what it is.

Thank you.

There was a regedit ‘hack’ for maxfilters or something like that, however it only worked for Windows 8.1 preview, not Windows 8.1 RTM, however there is one report here on the forum that the unofficial beta, which got its link removed, did in fact work on Windows 8.1 RTM however I do not use Windows 8.1 RTM so I can not confirm. If the unofficial beta does indeed work on Windows 8.1 RTM then I’d assume the next stable release will work on Windows 8.1 RTM.
Even though the unofficial beta might work, it is still rather unstable from my testing with it, I had to revert to an earlier image due to some issues with it.

You can install 6.2 by renaming the installer (once installed you have to rename the application files and make symbolic links with the original names). The best option is to get the 6.3 beta which works mostly fine.

Please note Version 6.3 is a ALPHA not beta, and as such can cause serious problems.

Just wanted to let everyone know, I downloaded the official release of windows 8.1 this morning and the firewall still doesn’t work, even with the registry hack. Save everyone a little time from trying. Hopefully there will be an update sometime soon. I will patiently look forward to it ;D

Please try reinstalling by following the advice I give in this topic and see if that helps.

Comodo isn’t working right for me either after installing Windows 8.1. I have no idea why, but after I rebooted my computer, Comodo said I installed ‘Internet Security Premium’, which I didn’t. Looks like it erased all my previous settings also or at least can’t load them correctly. Comodo was running fine until I installed Windows 8.1. Not sure if I should reinstall Comodo or wait for a possible fix.

Please try reinstalling by following the methods I suggest in this post.

Hi Chiron,

Thanks for the response. I tried everything in your thread but didn’t have any luck getting the firewall to work. I’ll go through it again but it looks like I might just have to wait until an update comes out.

Comodo free firewall didn’t work for me after I upgraded to Windows 8.1 on Thursday (shortly after the update became available). I reinstalled Comodo 6.3, but it blocked my wi-fi internet connection – I couldn’t communicate with the router’s IP address (for instance, by entering it in the URL field of my browser). I tried what I could think of, but then uninstalled Comodo (including deep search for registry and other remnants), and installed another free firewall at least temporarily.

Has anyone else encountered a problem with Comodo blocking wireless internet connectivity?

The problem will likely be solved if you reinstall by following the methods I suggest in this post. Also, run the removal tool in Safe Mode.

I have removed and cleaned and reinstalled the CIS 6.3 several times. But Firewall still does not work. Again. Again…

For each of those times did you run the Removal Tool in Safe Mode? If not then please try that and see if it helps.

Are you using the latest version, 6.3.294583.2937?

See https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-632945832937-released-t98364.0.html

I tried following the advice to uninstall Comodo in safe mode - it is not possible to uninstall programs in safe mode in Win8.1

I then uninstalled in normal mode, rebooted, downloaded the installer and ran it. Success - no issues.

I don’t know whether it is relevant, but I had applied the registry fix to change a 2 to an 8 before I uninstalled.

How does another free program editor, from 2006, not supported/updated anymore, work fine with 8.1 but
a supposedly state-of-the-art IS tool is broken, and for so long ? Makes my wonder if I am really safe anymore.

None of my other installed programs had an issue, just comodo.

Please do not Double/Cross post.

Thank you

Dennis