Comodo Firewall Installation

I’ve just installed Comodo Firewall 4.1. Immediately following installation and restart I get an error message stating PDFCreateHook Application has stopped working. This Nuance application is required to create PDF files. I tried unistalling Comodo firewall and reinstalling which resulted in the PDFCreatehook application working fine when Comodo Firewall was not installed but not working upon reinstallation of the Comodo firewall.
Any clue about what I might be doing wrong? I’m not looking forward to reinstalling the Norton Firewall but at least that worked with the Nuance application. As far as I can tell everything else works OK.
Help, please.

Do you have the Sandbox enabled? Do you have received any warning to let you know that this PDFCreateHook Application was sandboxed? Can you check the “My pending files” to see if this application is not there listed? When you find the application there, you can move it to the “My own safe files” and start the application again to see if this help.

Sandbox is enabled. No warning that application was sandboxed. It is not listed in pending files. I moved the application to safe files but to no avail. I even tried running it in the sandbox as unrestricted; even that doesn’t work. The error message is a Microsoft Windows message stating that PDFCreateHook Application has stopped working. The problem only exists when Comodo Firewall is installed. I am completly puzzled. I would appreciate any help.