Comodo Firewall Icon

This could be a bug. But I need more information.

Can you tell me if you tried making MWP a Trusted Application in Network Security Policy → Application Rules? If you didn’t please do so and see if that solves it or not.

Regarding D+ there is a list of known workaround described in App. is not working correctly, but does not seem to be s/boxed. What to do? [v5]. Could you try them all and see if any of them helps or not.

Hi EricJH,
TU. I do have MWP as a Trusted Application in Network Security Policy → Application Rules.
I doubt very seriously that its a bug; I don’t know if you looked at the icons in the Quick Launch Bar and the Notification Area in the screen prints I sent earlier, I could be considered paranoid when it comes to bugs (never had one and hope to keep it that way). I have Spybot, Windows Defender (just ran a full scan this morning), Malwarebytes, Super-antispyware, and I had AdAware until a couple months ago but I uninstalled it because it was a resources glutton. As a rule, I run a scan with one of the above two or three times a week; alternating full scans and quick scans.
I looked at the D+ reference you listed and some of that stuff is over my head; I’ll have to study it more closely and get back to you.
Thank you,

Hi EricJH, et at,
I just received and installed a BETA update from MWP and that has cured the loading problem. I want to thank everyone that helped me in trying to resolve this anomaly.
Thank you,