Comodo Firewall freezes System after Startup

This just killed my whole morning. Same symptoms, but I have been running Comodo AV+Firewall bundle for months. After last night, I found the laptop frozen, reboot - same thing. As soon as a few services load up, it freezes with all exactly the same symptoms - no ctrl-alt-del, no programs - just mouse.

After hours of desperate debugging and methodically disabling and re-enabling services and startup programs, I have zeroed in on COMODO Internet Security Helper Service. As soon as it’s disabled from Safe Mode, the computer boots fine, but Comodo starts asking a million questions about every program, as if it’s forgotten about any of its previous settings (not surprising, I suppose the Helper was the one providing them).

I’m running version 5.3.176757.1236.

I’m keeping the service off for now while I help you diagnose the issue. I like Comodo, and I like to be deeply involved with products I like (I’m a developer by the way, so feel free to throw technical things at me).

Attaching the diagnostics report that was produced by Comodo after I clicked on Run Diagnostics under “Comodo Application Agent is not running!”.

Also, I don’t have any AV software installed, but I used to run MS Security Essentials and possibly NOD32 until it ticked me off with networking bugs.

P.S. Your own forum doesn’t allow attaching .xml files that your own software produces. Maybe you should fix that. Renamed it as .txt.

Edit: wow, your forum mutilated the attachment really bad. Here’s a tinypaste instead (password: “comodo” with a small c - your forum keeps autocapitalizing the c): The easiest way to host your text

[attachment deleted by admin]

Hey and warm welcome to comodo forums archon810!

try to see if downloading and using the correct removal tools, in safe mode as admin,will help. ESET Knowledgebase

Valentin N

I’ll try when I get some time (it’s 5am now), but the fact that I’ve been running Comodo without freezes for many months and then it suddenly freezes points at a different problem, IMO. Of course, it could be something that’s triggering the old buggers now somehow. Any other ideas in the meantime?

if you install the SP1 to your computer disable AV realtime scanner. I download the complete SP1 both for 32bit 64 bit ( I think I will try 64OS since my computer has 64 processor)

Haven’t installed it yet. I’m on a 64bit Win7 btw.

I suggest you download the SP1 and then disable the realtime scanner.

Valentin N

I had this problem on 64 bit windows 7. The quickest way I found to solve the problem was boot in safe mode, Create another user account. Reboot normally and open this new user account. You’ll find it shouldn’t freeze, uninstall and re-install Comodo and it should solve the problem.

Hey and warm welcome to comodo forums inspiration8!

Thanks for you contribution to a solution :slight_smile:

Valentin N

I have the same problem. I do not use Comodo AV. I reinstalled Windows and Comodo 3 times. Even on a clean system (without AV), Comodo is not worked properly. For Windows 7 x86 everything was ok, but the x64 is the problem. With Comodo Internet Service Sercurity Helper Service computer will start in 20 minutes. Service off - computer works pertectly and start in 20 seconds, but does not work online. Anyone know 100% effective solution?


Rooney321, this is the third time you’ve posted the exact same thing.

Cross-posting is not allowed on this forum, one post is sufficient.

ok, sorry, but I’m already so desperate … :wink: is some annoying bug

also i have same problem! sometimes not all the time, system freezes and ‘win32 generic host error’ appears!!
i did’nt have this problem before installing firewall comodo!
note: i use firewall comodo + avast internet security

What do you mean with win32 generic host error? Can you show a screenshot of the alert you get?

I wouldn’t use an Internet Security Suite with Comodo Firewall; Make sure you have disabled either of the HIPS and/or Firewall’s of Avast Internet Security or Comodo Firewall

im not sure , cause of comodo or not?
i mean this :

im sure i have no viruses! i had boot time scan with avast!
but some hours before, avast! had an alert about"win32 confi".
after that i scanned system.

Do you have two HIPS enabled?

Can you check the Avast logs for the “win32 confi” alert? When I see that I think Conficker worm: Conficker Removal Tool - Free download and software reviews - CNET Download .

thanx for your help! i ran Conficker-Removal-Tool and after clicking atart button said no worm found.
am i run it in safe mode or not?
and about hips.i use avast! internet security with stopped firewall + comodo firewall.
i have trusted all processes and … in comodo and in avast! too.

anyway seems problem’s solved! because after 1 day nothing happend!

[attachment deleted by admin]

i have exact the same problem, uninstalled/reinstalled comodo about a month ago, which temporarily solved the problem, and today it started doing it again…

so i just now uninstalled it, and i’m quite hesitant about reinstalling it again.
any suggestions as to how to fix this problem?

(btw, i was using comodo firewall + kaspersky AV)

i had this problem if u see above posts.
then with trusting my AV processes in comodo firewall and comodo processes in my AV, problem solved.