Comodo Firewall freezes PC on Remote Desktop

Dear Sir or Madame,
I am using Comodo Firewall, version 3.5.55810.432 on a Windows XP-Pro SP 3 system. I have the following reproducible effect:
I have created a default (non-admin, non-power user) account with Remote Desktop privileges.

  • When I logon to this account locally on the host PC everything works fine.
  • When I did not login yet an logon to this PC using Remote Desktop everything works fine.
  • When I am already logged on tho this PC (locally) and try to logon via Remote Desktop (using the same account) the PC freezes and stops responding.

This is very annoying as I cannot work remotely anymore. I have to hard-reset the PC to make it work again.

I believe Comodo is the source as when I uninstall the firewall and switch back to the “normal” one provided by Windows XP, the issue is gone.

…this might also be a Defense+ issue… probably…?!

Hi,
Try connecting to the computer with Firewall \ Defense + Disabled. BTW, do you see any blocked events under View firewall events/ View Defense + events while connecting to the PC?

Regards,
Vicky.

I can do this when I am at home… I’ll report back (this may take a day or two though…)

No - there are no suspicious entries. I believe due to the freeze even if there should be one Comodo is probably not able to write them to the log anyways… :frowning:

Ok - with Defense+ disabled it seems to work. I logged on several times now without any issues. So it seems to be a Defense+ rather that Firewall issue.

What’s next? I wouldn’t want to leave Defense+ disabled… :frowning:

Hi,
Try selecting the winlogon.exe and smss.exe as trusted/windows application under Defense + ->Advanced ->Computer Security Policy and try to connect to the PC via remote.

Regards,
Vicky.

I’m afraid we are back at the beginning: Yesterday I tried to logon with Defense+ still completely disabled (the option where you have to restart the PC). But: It froze. So this means: It’s not Defense+ but the firewall again. I inspected the log - nothing suspicious.
I really wonder whether I am the only one. I believe it maybe related to the default (non-admin, non-power) user… probably…?! Can anyone reproduce?

Ping! (:WAV) (:LGH)

I am having the exact same problem.
Target machine freezes when remote desktop is initiated.

I switched from Kerio that just would not allow Remote Desktop through regardless of settings.

Comodo setup is done according to previous posts.

Comodo:3.8.64739.471
XP Professional SP3 32

Any ideas:

It was not Comodo in the end that caused the hang-up. In fact it were the nVidia graphics card drivers that caused this hang-up. As soon as nVidia got aware of that issue they fixed this bug in recent drivers. Now all works fine again.

The reason why I thought it was Comodo was due to the fact that RD worked if I had not logged in before. After uninstalling Comodo I was not logged in on the rmoete machine. So it seemed to be Comodo but in fact it was not.

Thanks MortenMacFly .
This was the problem- and it works perfectly now.
The funny thing was that when I was connecting via Kerio I never had the problem because RD did not connect, once Comodo allowed the connection the Nvidia bug reared it’s head.

Again thank you
DF