Comodo Firewall Fails To Update And Shows Error: 0x80072efd [M1067]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Yes, I can reproduce the problem every time I try.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Open Comodo Firewall GUI
2: Click on “Update” button
3: All 3 update elements fail to update. Get error messages. Overall error message is: “Error: 0x80072efd - A connection with the server could not be established”
One or two sentences explaining what actually happened:
Update to firewall program and scan updates fails
One or two sentences explaining what you expected to happen:
The 3 elements of the update to update satisfactorily
If a software compatibility problem have you tried the conflict FAQ?:
This is only an issue with Comodo Firewall, not any other software
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how U tried to fix it etc:
Tried Diagnostics. Said there was nothing wrong with my software. An error occured when trying to save the Diagnostics report. Tried multiple times.
Added “” to the Hosts file but didn’t change the errors.
A KillSwitch Process list, and a Full Dump made of cis.exe while the updating is attempted, can be downloaded from here:

See here:

Exact CIS version & configuration:
CIS 7.0.317799.4142
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS not enabled, Autosandbox “Untrusted”, Firewall: Safe Mode, AV not installed. Proactive Security = Active.
Have U made any other changes to the default config? (egs here.):
Yes, made the config changes to Firewall recommended here:

Have U updated (without uninstall) from CIS 5 or CIS6?:
if so, have U tried a a a clean reinstall - if not please do?:
Have U imported a config from a previous version of CIS:
if so, have U tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 7 64-bit, SP1, UAC = Default, admin account, no virtual machines
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a= Avast! Free AV, Spybot 2.3, IoBit MalwareFighter b=MSE

When you say that you tried reinstalling, did you follow the advice in this topic? If not, please do try following that advice. From my experiences the chances of it being able to solve an issue like this are quite high, although not 100%.

Before we worry about any other information I first want to make sure you have tried reinstalling by following those methods. Please let me know if it was helpful or not.

Thank you.

Hi Chiron,

Thanks. Yes, I have followed those instructions to the letter for reinstalling CIS and it’s where I get my new install from (7.0.317799.4142).

It still has the won’t update error.

Hi, just for information purposes - I too have this issue that has recently appeared over the last couple of days on two PC’s running XP SP3, one a completely new install from your suggested page and one that has had CIS installed and updated for at least a year without issue up till now. Curiously, if I update from the onscreen widget CIS appears to update, but will not update from the main console. The console also shows anti-virus signatures to be out of date and Windows has triggered a security warning about CIS possibly out of date on both machines. Judging from the amount of readers of this post already, I would guess there are a few users of CIS having the same problem right now. Given that XP is no longer supported by Microsoft it may not even be a CIS issue in my case - but who knows? Hope this is useful to somebody.

ed1975, to create the Process List please follow the advice here. Let me know if you have any questions.

Also, please leave KillSwitch open after doing that. Then right-click on the cis.exe process (which is the one right above Killswitch.exe) and select to create a Full Dump. Then put that dump file in a zip file and upload it to a file sharing site, such as this one.

Let me know if you have any questions about any of that.

@ Gazzaweb, do you receive exactly the same error code as ed1975?


Hi Chiron, I would love to be able to confirm that I was receiving the same error code as Ed but I am delighted to say that just triggered an update to make it fail and now all is working perfectly well again. Update was smooth and windows security warnings have gone. From memory I did get a similar error code to Ed but cannot say if it was the exact same one. If this is down to the incredible work you guys do, then thank you - if not I will post again with more detail if the the issue re-appears.

Thanks for the speedy response.

I do know that for the last few days there was not even an update issued. Perhaps that is what you were experiencing. Regardless, I’m very happy to hear that everything is working for you.

@ ed1975, are you still experiencing the same problem?


Thanks, Chiron.

I am still experiencing the issue.

Here’s the link to my Dump and Killswitch:

Thanks, Ed1975

Thank you. I have added that information to the first post. The only important information I can now see missing is that you have not yet listed those security programs which used to be installed on your computer, but have since been removed. Please let me know which security programs those may be.


Hi Chiron,

The only security software I have removed from my PC recently is Microsoft Security Essentials. I put on avast! Free AV in its place.

Malwarebytes Antimalware, Spybot, and IoBit Malwarefighter have all been on my PC since I installed this copy of Windows last September.

Thanks, ed1975

Was this Malwarebytes Free or Malwarebytes Pro?


Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Hi ed1975,

Could you try this work-around?


The devs have not been able to reproduce this and believe that it may not be an issue caused by CIS.
However, the devs have requested that you open c:\windows\system32\drivers\etc. Then find and open the hosts file using notepad. Then please attach the contents of it to your next reply, or if you wish you can upload it to a file sharing site and send me a download link.

Thank you.

I’m sorry, but as the devs cannot replicate this, and there has not yet been a response, I am assuming this is likely fixed. I will therefore move this to Resolved.

If you find that this is still happening for you please let me know.

Thank you.