Comodo Firewall doesnt start at windows boot [resolved]

Hi, my comodo firewall doesnt start at windows boot. There is also no entry for it in the startup list. My Nod32 Antivirus doesnt start at boot neither, and the problem appeared at the same boot for both applications. Both apps work perfectly when started ‘by hand’. Any ideas?

Do you have any other security software running that could prevent the registry being updated?

Ewen :slight_smile:

No, just Comodo and Nod32. Anyway, how could I correct this? Seems to me the only thing to do is reinstall… :THNK

You don’t need to re-install. That’s reserved as one of the last resorts.

Please refer to this related topic:,6515.0.html

Yeah that guy’s situation resembles to mine. However i am not at all familiar with regedit. Do u happen to know TuneUp Util? I use it on an everyday basis for registry cleaning and last week i used it to change the WindowsXP boot screen graphics. One other thing i suspect of is Spyware Terminator which i installed to perform a virus scan on my disk and unistalled afterwards (due to slow pc performance). Does any of these seem relative?
Thanks for the attention anyway, i know there are much more serious problems than mine ;D ;D

Regedit is Windows’ own registry editor, so that’s why there’s no need for a 3rd party app. Ironically, it’s due to those 3rd party registry editors that usually cause this problem in the first place ;D

I use RegCleaner and HijackThis (both classics), but there are no real-time features. That’s probably why I don’t have such problems. Anyway, manually do-it-yourself-steps:

  1. Open up regedit.exe (run it from the start menu run command) and navigate yourself to:
  2. Right-click to create a New String Value. Name it COMODO Firewall Pro
  3. Double-click this new key and assign the value string as “C:\Program Files\Comodo\Firewall\CPF.exe” /background

(Note: Enter exactly as per the bolded highlights, including the quotes where applicable)

Proceed at your own risk! Backup your registry prior to making any changes if you don’t feel comfortable.

OK i did as told, nothing happened, Comodo still doesnt start at boot (:AGY) Was i supposed to ‘save new settings’ or something? The new registry entry still exists though…

In the thread I linked above, I referenced msconfig. If you run this (another Windows utility) does CFP even show up as an option?

Also make sure that there is a Comodo Application Agent service up and running in Automatic mode (type in services.msc in the run command - yet another Windows utility). This isn’t the GUI itself; it’s the CFP engine.

PS: There is no ‘save new settings’ in regedit. All changes are saved in real-time.

Edit 1: Please note this is for XP. If you’re using another OS then I don’t know if it’s the same registry path.

Edit 2: If the above still fails then try to manually create a shortcut to cpf.exe (the GUI) and drag it in your Startup folder (e.g. path: C:\Program Files\Comodo\Firewall\cpf.exe)

[attachment deleted by admin]

Well, there is an entry for Comodo in services.msc but there isnt one in msconfig, and not to mention that the problem is not solved yet. :-[ :-[ I have also restored all options i had applied with TuneUp since last week, but nothing good came out of it neither. The funny thing is that i have the exact same situation with Nod32 :BNC :Beer

I created a new registry entry in the folder …/Run/Comodo Firewall Pro

Um, where exactly is the startup folder??

:BNC Problem solved!! All i had to do is put the applications’ exe in startup folder. (:KWL)
Thanks guys!! (:CLP) :Beer

That was almost a last resort because the standard startup should be there. If your nod32 is experiencing the same then there must be something preventing them to start up properly or some conflict during the installation.

At least it works now. :slight_smile: If you need to open this thread again, contact any mod.