Comodo Firewall doesn't remember rules

I have searched on here and it seems that a lot of people have this problem when the program resides on a volume other that C. In my case, I have encryted drives using Truecrypt.

Has anyone found a solution to the problem that every time I start an application that resides on another volume, then I get asked for the permissions again? Checking the “Remember setting” box has no effect.


Comodo sees “mounted devices”, like USB sticks, USB drives etc, as unsafe and will not remember the rules you made. It is by design; I think it sees Truecrypt disk also as such.

OK, understood. What a great pity. Truecrypt has got to be one of the best bits of software around. This behaviour of Comodo Firewall makes me want to change it to another firewall, rather than the sacrifice any of the other apps I have on my encrypted volume.

Not quite true; it does actually remember and save the rules. Unfortunately it ignores them, but they are still saved. Each time you answer “Yes” to the question about saving the rule, a new identical copy of the rule is saved. After a while, you’ll have lots of duplicate rules about programs on your Truecrypt drive.

Really? I didn’t know that. So presumably, my disk is filling up with hundreds of duplicate rules that are being ignored.

Do you know a way to view them all and maybe to clean them? It’s got to be worth a try. And I am pushed for space on my C: drive, so every little helps.

They’re under Firewall/Advenced/Network Security Policy (or at least was in version 3). I’d guess that deleting them will save you about a hundred bytes/rule, so you wouldn’t even notice it in terms of hard drive space. They do create quite a mess in the Comodo config though.

If this is “by design”, it’s a bad design!

I have this exact same problem, except it don’t matter what drive it’s on. After every reboot I have to tell Comodo Firewall to never sandbox my defragger, and the “Remember This” checkbox is always grayed out… :frowning:

I have just found a solution for this issue when using with Foxit Reader, as follows.

  1. Close Foxit
  2. Go into the Firewall rules and delete all references to Foxit Reader under Firewall, Advanced, Network Security Policy.
  3. Navigate to Foxit Reader.exe
  4. Rename to foxit.exe
  5. Start Foxit.exe and accept it within Comodo firewall.
  6. Change the target of the shortcut links to point to just foxit.exe, rather than foxit reader.exe

I have no idea why this works, but it has done, for this application at least.

Apparently Comodo has a problem with filenames with spaces. You could probably have renamed the file to Foxit_Reader as well. The program I’m having problems with is Magical Defrag 3, but the file name don’t have any spaces in it.

sorry to bring this thread back from the dead if this problem has been solved elsewhere, but I just got Comodo Firewall 5.8.213334.2131 to respond “correctly” to applications launched from a portable drive.

  1. Launch the portable application and let Comodo make its popups
  2. Either make a rule or don’t make a rule, I don’t think it matters…
  3. With the portable application left running, navigate in Comodo to Firewall (top bar)
  4. Navigate to Network Security Policy (bottom left)
  5. Remove any rules associated with the portable application (click on the rule, click remove to the right)
  6. Click “Add…” in the top right to add a new rule, a window titled “Application Network Access Control” will popup
  7. Click “Select” in the top right, then “Running Processes”, then navigate this list to find your currently running portable application
  8. Click the “Use a predefined policy” radio button, then select “Trusted Application” from the dropdown
  9. Click Apply, then that window will close, click OK, then exit Comodo close all applications and restart your computer

I’m not sure why this works, but I’ve read that Comodo is designed to not like programs launching from external drives. So if you define your portable application as a trusted program after its been loaded into your native memory, as opposed to while its loading from the flash drive, I think comodo views it differently and will let it slide.

Good Luck to Everyone


I just tried the above workaround in Comodo 5, but it doesn’t work. I still get the popup after mounting the drive.

Thank you chris.antonellis :-TU

worked like a charm for my truecrypt drive.