Comodo Firewall doesn't install

I installed Comodo Firewall for my friend who has a Dell XPS laptop. It has an Intel N1030 Centrino wireless adapter and a Realtek PCI e GBE ethernet adapter.

I can’t install Comodo Firewall on this system :o

I connected the ethernet cable from his Fiber box to his ethernet port and connected to his PPOE connection and the connection works.

I downloaded Comodo Firewall and tried installing, it never installs completely. It is stuck at around 68% and it doesn’t move. It is a clean Windows 8 system without any other security software other than the default Windows Defender.

I tried several times and I stopped.

Then I connected to his router using the Intel Wifi adapter after connecting the ethernet cable from his Fiber box to the router and I installed Comodo Firewall and it was successful.

Why is that?

He had a BSOD a while ago and Comodo Firewall was the culprit and I had to remove it.

Where did you download it from?
Is it v5 or v6?

Please try installing it by following the methods I advise in this post and let me know if that works.

You could install comodo when the cable is not plugged. Whatever the reason might be.
Sail around exotic bugs :slight_smile:

CIS v5.10 or 5.12 should have a fix for a problem with pppoe adapter.

Thanks for the replies. I am using Comodo version 6 and well, without connected to the internet, it won’t even go past 40%.

Yes this is truly an exotic bug. I am puzzled.

I downloaded it from both the link at the forum and Comodo Firewall webpage. I tried both files. I even got Internet Download Manager and tried downloading and installing that file.

Still it won’t install.

Would be grateful is someone can tell me the official hash of the Comodo install file. Just to be sure probably the 15th time.

Even after I install after connecting via the Intel Wifi adapter, sometimes, it takes hours for the Comodo program to pop up. Sometimes, it doesn’t. I just see an invisible Comodo Taskbar icon. I click on it and nothing happens. I have to uninstall and reinstall again.

I am on Windows 8 64bit and Comodo Firewall doesn’t disable Windows Firewall as well and doesn’t detect new networks.