Comodo firewall does not start


I have problem with Comodo (circa 2 weeks, maybe after win updates?). I have win 8.1 Pro 64b. I have windows updated, firewall in latest version. I tried uninstall Comodo and I made clean installation. It did not help. I made partial recovery win 8.1, installed Comodo and it still does not work. Comodo service is running.

When I click on Comodo icon that I have on desktop. Comodo starts immediately.

When I restart my PC I have in task manager this:
running: cavwp.exe, cmdagent.exe
runing: comodo service

cis.exe and cistray.exe does not run (and when I click on Comodo icon on my desktop), Comodo starts and cis.exe and cistray.exe too.

I use Avast free, but even I uninstall it Comodo does not work.

I tried uninstall Avast and Comodo and I installed complet CIS, but there is the same error.

Anybody has any solution?

thank you

I tried CIS 8 beta and there is still the same problem.

There is already a thread on this problem

Yes I know but the solution does not help me from here and there is nothing about version 8.

Did you download the fix or didn’t you see it?

There is no fix. There is only a menu how to put it in autorun and I can put it there manually (if nothing changed, I did not look there for few days). It is not a solution.

Look at Post #14 by qmarius … there is an attachment (temporary fix) you can download. It is a missing registry entry that causes cistray not to load at startup.

Hi pjb024,
I will just add clarity for the other users.

The mentioned registry fix is a workaround while the Developers look into why the required scheduled task is not functioning on some Win 8.1 systems.
Also the mentioned post is in another topic which can be found in the link below. :wink:
Comodo firewall not running at startup-Reply 14

Kind regards.

I just managed to get around the issue by rearranging the order of OS and firewall installs.

Any idea when Comodo devs are properly patching this/releasing a good build :-
Thanks in advance :-TU