Comodo firewall crashes after notebook is taken out of rest mode [292]

The bug/issue

1. What you did: Open the lid, press “on”-button, click on my user name (…“6 applications running”). Wait for notebook (Dell XPS M1530) to come out of XP rest mode.
2. What actually happened or you actually saw: First thing coming up is “Comodo has crashed”. I check that there is a file in the error report, click “send report”, couldn’t be send even though I am online already. Next thing is a system message “system unit has been installed, needs a restart”. I have no idea whatsoever what this is about, haven’t restarted yet since I have a lot of unfinished work open.
3. What you expected to happen or see: No message from Comodo, which I expect to do its magic in the background. I expected to transfer files from my SD-card, start working in Firefox and Word. Usually, though, Comodo tells me it found a network when I open the lid, and tells me the same the second my WLAN catches on. I usually abort this, since I already defined my home network, and when I give the supposedly “new network” my home network’s name, it just says that this network already exists.
4. How you tried to fix it & what happened: I have no idea what has happened, so I could not fix it. Searched for “crash” on my hard drive and found a file related to Comodo. Tried to restart Comodo, but even though the icon is there, it does not show up in the list of running files, and the icon is non-clickable. It shows one arrow of outgoing traffic and is frozen like that.
5. If its an application compatibility problem have you tried the application fixes?: I don’t know what might have been involved.
6. Details (exact version) of any application involved with download link: None directly implicated.
7. Whether you can make the problem happen again, and if so exact steps to make it happen: Hasn’t crashed just like that before (“only” when running Age of Empires 2 the other day), and I have way too much work open and waiting to restart and fickle now. I thought I ran finished, non-beta software?
8. Any other information (eg your guess regarding the cause, with reasons): No clue.

Files appended

1. Screenshots illustrating the bug: Only a “new network” screenshot that keeps popping up all the time.
2. Screenshots of related event logs or the active processes list: -
3. A CIS config report or file. Can’t start CIS for the moment, see above.
4. Crash or freeze dump file: The file attached had an original ending .pf, I renamed it .txt to be able to attach it here (

Your set-up

1. CIS version, AV database version & configuration used: Freshly installed last week or the week before.
2. Have you updated (without uninstall) from CIS 3 or 4, if so have you tried reinstalling?: No.
3. Have you imported a config from a previous version of CIS, if so have U tried a preset config?: Config as it comes online, I only made some applications “trusted” (Age of Empires 2, AVG Free, Firefox).
4. Defense+ and Sandbox OR Firewall security level: High, but without the one where all my traffic goes via a Comodo-server.
5. OS version, service pack, no of bits, UAC setting, & account type: Windows XP Professional SP3 fully updated, 32bit, admin.
6. Other security and utility software running: AVG Free. The following programs were in the taskline:

CPUID Hardware Monitor (fully updated)

Windows Explorer (XP fully updated)
[OS included]
Mozilla Firefox (fully updated)

Word 97
[OS included]
GIMP (fully updated)

… in the system window next to the clock:

Foobar2000 (fully updated)

Bluetooth software (Dell)
AVG Free (fully updated)

7. Virtual machine used (Please do NOT use Virtual box): No.

[attachment deleted by admin]

Thanks for following the format. Should you be able to add a CIS configuration report or file later (see red links in format for how), that would be greatly appreciated. However you have given the critical information for reporting a crash, so I will forward to format verified.

Best wishes


Turns out Comodo crashes upon restart, just like it did when I played AoE2 the other day. Configfile is attached.


P.S.: cisFirewall.cfgx renamed to cisFirewall.txt since I can’t post the original config file here… ;D 88)

[attachment deleted by admin]