Comodo Firewall Contantly prompting for Reboot (Solved)


New poster but long time user of Comodo Firewall. Would like some advice on a couple of queries.


Windows 7 SP1 (fully patched and up to date)
Comodo Firewall 5.5.195786.1383 (fullly up to date)
AVG AV free (fullly up to date)

Comodo Firewall keeps on prompting on system tray that their a update. The following happens

  • Comodo prompts that their update available.
  • I initiate to allow the update to proceed.
  • Update progress bar / box flashes up literally for a second
  • Comodo prompts that the update is complete and prompts for reboot.
  • PC fully reboots and Windows is loaded.
  • Comodo prompts that their update available

This loops as i dont think either the update is working properly or that there not really a update but comodo thinks it still in the middle of updating, perhaps the agent is broken?

I was going to uninstall and clean install but i have a lot of application rules set. Which brings me on to my 2nd query. Is there anyway that i can backup the firewall application rules and reimport them onto a new install?

Any advice would be most welcome.


Hi cskyo,

Quote from;msg552759#msg552759

Updated 10/20/2011: Program updates are released as of today. Updating from CIS 5.5 to CIS 5.8 There will be a 2 stage updating mechanism for old users. The initial update will be updating the updater to the latest version which is capable of upgrading to CIS 5.8.

Updating from CIS 5.8.x.2124 to CIS 5.8.x.2131

If you have CIS 5.8.x.2124 installed, you will also receive a small update. Pls check the updated release notes for details.

Have you tried to manually update via CIS > More > Check for update? You may try to see if it makes a difference in the updating process.

Thanks for the reply

I tried to manually do it as well through the menus, but it never made a difference. :frowning:

Anyone that interested,

5.8 installer works fine. But the installer from the main comodo site is broken and can end up downloading a different installer from your selection. In end I just installed from a mirror Techspot which had the 64 bit installer. Did a clean install (removed old) and things seems to be working.

My build was from ver. 4 which is too old to upgrade to 5.8

Hope that helps anyone.