Comodo firewall completely broke latest windows 10

Writing from mobile… Your firewall completely broke windows 10 network functionality.
Bsod on installatuon finish, then on reboot it cannot start but guess what - no network. Not present in the add remove programs, had to manually delete all services, reboot - no net.

So i booted with a live cd, deleted it from program files - still no network. Removed all comodo entries with autoruns - still the same.


Hi and welcome to the forum,

First, Comodo Internet Security (And Firewall) only officially supports Windows up to Windows 10 TP build 9926 so far, issues with later builds are to be assumed expected since CIS does’t officially support those versions.

Now, I’m not quite sure I understand the exact situation right now, are you able to boot into system and log-in but you have no network? Or are you unable to boot or log-in at all?

If you are able to boot either into the live environment or safe mode, have you tried these steps: Comodo Forum

If you’ve tried them but the issue is still present then you could try going to Control Panel (Not Settings app) > Network and Internet > Network and Sharing Center > Change adapter settings (in left menu) > Right-click your NIC and click “Properties” > In the new window, find “COMODO Internet Security Firewall Driver” and disable it then uninstall it.

Reboot and try again, if you still don’t have any network then you can try removing C:\Windows\System32\drivers\inspect.sys if present (This is a driver for Comodo’s firewall)

If nothing of that works then send me a PM and we’ll try one last thing.

Also, I’ve noticed myself that the firewall breaks when updating Windows 10 builds to newer builds, for future reference you may want to consider uninstalling Comodo Firewall before updating and then re-installing afterwards.

Edit: I just noticed this is in the bug board, I thought it was in the help board, so not sure if you’re only looking to report the bug or if you want help with the issue.

Wow I cant believe I did not notice the driver in the adapter… Network works now. Do you have a custom uninstaller or a way to cleanly uninstall? The cif does not appear in add remove programs…


I’m afraid I’m a bit pre-occupied at this moment but I will send you a PM later today (Today as in CEST ;)) with some further steps to clean up the left behind installation/remnants of Comodo Firewall.

Edit: PM Sent.