COMODO Firewall causing very high PINGS in Windows 7 64-bit

Dear Users,

I’m running Windows 7 64-bit (build 7600) on my PC, along with Comodo Firewall (also 64-bit latest version).

I’ve spent the last 2 days on the phone with my ISP trying to figure out why I’m getting insanely high PINGS when I do a test on, with no avail.

Until… I stumbled across this post:

This is EXACTLY the problem that I had, and once I completely uninstalled COMODO Firewall my pings went back to normal (no more than ~20ms vs. the previous 500ms+).

Right now comodo is uninstalled and I am using Windows Firewall. I would much rather use Comodo Firewall but since I have no clue as to how to solve this issue I can’t.

I found a post about this issue here on the comodo forums:

However the post is dated 2009 and is filed under resolved/outdated bugs, suggesting that this issue supposedly has been resolved already. However, obviously it has not been since I’m experiencing it right now with the latest version of Comodo Firewall, so if there’s a solution I would love to hear it…

Any help/ideas?


Is the problem only with Or also with other sites. Try pinging to and for example.

The problem was not only with but with other speed tests that I’ve performed that were provided both by my ISP and my Cable company (which provides the infrastructure) respectively. Both these tests are done with local servers to guarantee the best possible results. And also when I did the test using I made sure to test with local servers as well (I’m from Israel) since obviously remote servers will always have higher pings and are not an accurate indicator.

When pinging directly from CMD using the ping command, all the pings come out normal (Including and I’m guessing that direct pings from the command prompt are not monitored by COMODO Firewall the same as pings made via website services and thus are unaffected by this bug.

Right now without COMODO Firewall installed all the pings have returned to normal on all the tests I have previously performed, down from ~500ms+ to around ~20ms, which is a significant difference.

Thanks for your reply. I will keep on asking to see how far I can narrow down the source of your fiding

Testing speed may also vary with used browsers. Opera is known to perform less on Speedtest for example. Is the behaviour consistent when using different browsers? When testing make sure to clean the browser’s caches before running a test.

The behavior is consistent when using both Firefox 3.6.10 & Explorer 8 on Windows 7 Ultimate 64-bit.

Just so there are no misunderstandings, the fault is clearly with Comodo Firewall. We are not talking about some minor differences in results which can occur because of differences between different browsers. We’re talking about very high pings of 500+ ms which immediately went down to ~20 ms or less once Comodo Firewall was fully uninstalled (disabling it does not help only a full uninstall).

I do not know if this problem is a general problem with Comodo Firewall 4, or if it’s a specific combination of Win 7 64bit and Comodo Firewall 4 64bit which is problematic. So maybe if I had Win XP 32-bit + Comodo Firewall this would not be a problem. But it’s definitely an issue with Comodo Firewall.

P.S - I hope you read the link to the other forum discussion I provided about this problem:

And also the post on the Comodo Forums:

Please note that on the above post from the Comodo forums a solution was never offered either and so I don’t know why it was filed under “resolved/outdated bugs”. Clearly this issue is still prevalent.

Since the problem is still around with v5 , and was reported a while ago, I would suggest to file a new bug report. May be it went of the devs radar.

When you are submitting the bug please follow FORMAT & GUIDE - just COPY/PASTE it!.

I’m running Firewall v4.1 and have no problems with high ping whatsoever. Maybe there is an incompatibility with another program on your computer. Have you added it to your antivirus exception list?

Similar report here:

+1 :-[

I have installed CIS 5 today, before that I had KIS 2010(+2 years license).

Speedtest with KIS 2010 installed…

Speedtest with CIS5 :o

I tested my download speed with a real link. with KIS I could download with more than 10MB/s but with CIS 5 is only 1MB/s. :-[

What is wrong? what I have to do to have my speed back(Uninstalling CIS?)?


364 Mb/s :o only wish we could get anything like that in the UK, max we can get is 50Meg on fibre optic.

Just to confirm, is this with 64Bit windows?

Hello Matty_R, Max speed that we could get in Sweden is 1000Mbps which is new and it’s few people that have that.

Yes it’s with Windows 7 Home Premium 64bit on Asus M60J.
I have changed one of the HDD on Asus m60J with Seagate Momentus XT 500GB.

With Kaspersky IS I can use my real speed but not with CIS5 ???

Please make sure all KIS traces are removed from your computer. Run this tool from Kaspersky.

I do not really suffer from high ping times as far as I’ve noticed, but seeing the speedtests made me go and test it for myself. I am running the last version of Comodo FW v4.x

I am running Win7 64bit

test with IE 8 64bit (clean, no addons) in normal mode:

test with Firefox 3.6.10 (few addons) in normal mode:

test with Firefox 3.6.10 in SAFE mode (no Comodo loaded then ofcuz):

The last is the speed I should be getting as I have a 120Mb/10Mb connection from my ISP.

Thing is that in utorrent I do sometimes get like 12-14 MB/s (so thats the “almost full” to “full” dl speed)

I also use cFosSpeed v5 traffic shaper to make sure I get the best speeds available.
I haven’t really tweaked utorrent for better speeds as I figured it’s not really needed.

So the problem really does seem to be the combo of browsers with Comodo.

tried a test with Opera 10.62 in normal mode on a different server (but one with normally reliable results like the one in Amsterdam, actually it’s close to Amsterdam, in Haarlem)

Slightly better download, but still not optimal.

It takes away about a solid 40 to 50Mb, which I consider a lot as it is 1/3rd to almost half of my total download speed. Any idea why this could be the case? As you can see the ping times are quite okay.

(P.S. I had no other up or downloads running while performing the tests ofcuz, and I havent had any other firewall/AV then Comodo and Avast Home Edition since my clean install of Win7 at the beginning of August this year))

(P.S.2: On a more positive note. It can always be worse. I just thought I’d try the next best firewall that spose to be Online Armor (Premium Trial version, and now I get no more than max 10 Mb download speed on LOL! So back to Comodo it is. :P)

[edit] Oké, so I solved the problem. I was thinking that the combo of my AV + FW might be the problem. So I disabled the Network and Webshield in Avast Home Edition and did the speedtest on again.

Looks much better ey? :wink:

I also installed the latest version of Comodo v5. It runs smoothly as a baby’s bum. Me like :slight_smile:
Comodo ftw!

I also tested local file copies on 2 gigabit enabled machines on a local LAN;

Copy 3GB with firewall enabled = 280Mbps
Copy 3GB with firewall service detached from NIC = 360Mbps

Test setup;
Laptop 1Gbit NIC, Win7 (Source) CIS 5.0.x.1135
Server 1Gbit NIC, W3k2 (Destination) share over TCP445, no FW.

Ok, original author of this thread here…

I just installed COMODO v5 (before that I had v4), and tried doing the test again. Pings were back to normal.

Whatever it was in v4 that was causing the problem seems to have been solved with v5!

Version 5 looks awesome btw, so I’m pretty happy to be using it! :slight_smile:

IMPORTANT UPDATE: I found out that it’s a combination of COMODO Firewall and ESET NOD32 Antivirus that’s causing the problem.

Install either one of them separately, and everything is fine! But once you install both of them concurrently you’ll get this issue with very high 500+ ms pings!

I figured this out completely by accident after trying ESET Smart Security 4 (Firewall + Antivirus bundle) because I wanted a good firewall to replace COMODO. Using it I had no issues with pings, everything was running smoothly.

Today I decided to try out COMODO Firewall v5 to see if this issue was resolved with the new version (since preciously I was using v4), and also because I really like COMODO’s Firewall and wanted to use it again.

Anyway long story short I had to do a full uninstall of ESET Smart Security 4 (uninstalling both antivirus & firewall because you can’t uninstall them separately with ESET Smart Security 4). And then I installed COMODO Firewall v5 and did the test without having any anti-virus software installed. Pings were perfect (very low), and so I proceeded to write the above message saying the issue has been resolved with v5. But as soon as I installed NOD32 antivirus again, and did the test again, I was once more getting pings of 500+ ms.

I uninstalled ESET NOD32, and the pings went back to normal! I then tried re-installing it, confirmed that the pings were once again very high, and then uninstalled COMODO Firewall v5. After that again the pings went back to normal.

So the conclusion is that there is some kind of unwanted interaction between these two programs where if you have both of them installed at the same time you will get very high pings! Uninstall either of them while leaving the other and the problem is resolved.

I’m really not an expert either of these two programs. All I know is what I described above. Any knowledgeable people on here have any ideas as to what may be causing this issue when these two programs are installed side by side?


Okay, after some more digging around I found a solution to this problem :smiley:

Check out this forum post:

I traced the problem to a security feature on ESET's NOD32 v4.0.467.0 for Windows 7. I can confirm that unchecking "Enable HTTP checking" in "Advanced Setup -> Web access protection -> HTTP, HTTPS" pretty much sorts the problem out

A restart may be required for these settings to take affect!

Now both NOD32 and COMODO v5 are installed side by side and working perfectly. Pings are nice and low! :]

Good Luck to anyone having this problem… Hope this helps!

Thank you for the report, quanzaboy.
This should prove useful to anyone else with a similar issue.

Yeah no problem, I’m glad to help out the community!

By the way, and this is totally unrelated, but I noticed in your signature that you have the CPU-Z validator, and that you’re running an i7 OCed @ 4.21GHz… Can you please tell me what cooler you are using with this setup and what are your max load temps? :smiley: Haha… sorry I know this is so off topic, but I’m really interested to know! :smiley: