Comodo Firewall causing slow shutdown

Hey all, I had recently bought a new laptop and then installed Avira and Comodo as my firewall. I notced after installing comodo, that I would get very slow shutdowns. My shutdown speed without Comodo is roughly 10-15 seconds while with comodo I was near 90-110 seconds. What would happen is I shutdown/restart and all my programs would close, and I would just stare at my desktop screen for a long time. I could open Firefox and do things, while it would just sit there. My harddrives were not working hard as the indicator light was not flashing, it was just in a neutral state. Then finally it would log me off and shut down. I didn’t know it was Comodo at start so I reformated my computer and then reinstalled Comodo again. Still, after installing Comodo I would get long shutdown times. I finally uninstalled Comodo and now back to fast shut down times.

I really want Comodo as my firewall, but I don’t want to have 100 second shutdowns. Does anyone know what is causing this problem and how to fix it? Thanks! :slight_smile:

Greetings!

I myself have no problem with the shutdown, only takes about 5-10 seconds. I guess there’s some conflict with one of your other security softwares. What other security softwares do you run together with CFP?
When shutting down the computer, go to the logs for Defense+ and see if it’s blocking something. Also, it might be worth to take a look in the Event Log.

Cheers,
Ragwing

my shutdown with or without Comodo takes about 5-6 seconds. Like Rawing says sounds like a conflict. I also use Avira Premium. You can modify your registry for faster shutdowns by going registry editor and find the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control. Then modify the ‘WaitToKillServiceTimeout’ and change it to 1000.

Go to Start then select Run
Type ‘Regedit’ and click ok
Find 'HKEY_CURRENT_USER\Control Panel\Desktop'
Select ‘WaitToKillAppTimeout’
Right click and select ‘Modify’
Change the value to ‘1000’
Click ‘OK’
Now select ‘HungAppTimeout’
Right click and select ‘Modify’
Change the value to ‘1000’
Click ‘OK’
Now find ‘HKEY_USERS.DEFAULT\Control Panel\Desktop’
Select ‘WaitToKillAppTimeout’
Right click and select ‘Modify’
Change the value to ‘1000’
Click ‘OK’
Now find 'HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control'
Select ‘WaitToKillServiceTimeout’
Right click and select ‘Modify’
Change the value to ‘1000’
Click ‘OK’

I did all those things and still getting a slow shutdown. How do I check my logs? The only security programs that I am running are Avira AV and Comodo. I had Windows Firewall but turned that off. Also had Norton installed on the laptop but removed that program when I first got m laptop. I am 100% sure it is Comodo because I just installed it again and it’s causing me to have very slow shutdowns. Please help :frowning:

I could not find any of those waittokill things except the last one. I already edited that when tweaking my Vista.

It turns out to be the Defence+ that is causing the problem. I disabled it and my laptop was shutting down at normal 10 second speed. With it activated, I have to wait close to 2 minutes! So what should I do?

Hi BryanL,

Try to set Defense+ to training mode for a couple of times just before shutdown (don’t forget to change to previous mode afterwards).

I believe it is my Synaptic Touchpad driver as it shows it in the Defence+ log everytime I restart. But I dont know if I should uninstall this program. I went to msonfig and turned it off at startup so its not running but I am still getting long shutdowns. I still think its this driver though. Not sure

Is the log saying its accessing memory?

Yes it says it. But I disabled Synaptics at startup so it wouldnt run and I was still getting slow shutdowns :frowning: WHen it was disabled, there was no log of Synaptics trying to access memory.

You need to add Synaptics to the memory access permissions. Simply go to D+\Advanced\Computer Security Policy\Comodo Firewall Pro. Click on edit once you highlight Comodo firewall pro. Then click protection access. Then click modify next to interprocess memory access and add Synaptics from running proceses. Click apply,apply,apply and reboot.

Did all that, still getting slow shutdowns. This is what my system log looks like:

http://img257.imageshack.us/img257/5818/comodozw1.jpg

Don’t know if it will work for you, but you might want to look at:

http://download.microsoft.com/download/a/8/7/a87b3d05-cd04-4743-a23b-b16645e075ac/readme.txt

Regards,
Mike

I also noticed slow logoffs with Comodo - it seemed to take much longer than normal to save your settings back to the domain controller for a local user account. I have comodo in CleanPC mode - should I change it to a different mode to get whatever rules are necessary created?

Still nothing so I had to shut down my Defence+ and now using Avira and windows defender

I suggest to all of you who have problems with slow shutdown whatever is it hooking problem or something else to defrag system partition.

Defraged my system, turned off Windows Defender and everything, still getting the long shutdowns :frowning: 2 mins!

Are you still getting memory access alerts in your D+ log?

Yes, it was. Here is a screenshot:

http://img365.imageshack.us/img365/5576/capturedb9.jpg

I did what was said earlier and allowed access but it’s still causing the problem. Even when I had Synaptics drivers not turned on (turned them off as startup proram) it would still be very slow 2mins shutdown. :frowning:

edit: looks like the picture gets distrorted. Here is a link http://img365.imageshack.us/img365/5576/capturedb9.jpg