Comodo Firewall Bug: System Hangs or Unable to browse internet or open apps

I’ve had a few weird issues with comodo firewall where one of these two happens.

  1. Either at a random time of the day the entire system hangs for like ~10 minutes then the computer runs a little ■■■■■■ so I’ll need to restart.
  2. Randomly unable to browse the internet and opening apps, if I wait it out it will eventually open, but then may stop responding, once again a restart fixes it.

After uninstalled Comodo Firewall these issues are gone. I have no other antivirus installed and windows defender is disabled.

Bug Report in Proper Format:

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?: No, happens randomly.
?
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
Happens totally randomly as far as I can see. However it may be coincidental, noticed it happens sometimes after watching a video/stream, also sometimes after relaunching the program. But once again can be just coincidental.
One or two sentences explaining what actually happened:
N/A, bug happens randomly when running.
One or two sentences explaining what you expected to happen:
N/A, bug happens randomly when running.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Yes, fully uninstalled Avast and restarted and still occurs when CIS was my only line of Defense. So Avast is not the cause.
Any software except CIS/OS involved? If so - name, & exact version:
No.
Any other information, eg your guess at the cause, how you tried to fix it etc:
I have no idea how I would even start fixing it.

B. YOUR SETUP
Exact CIS version & configuration:
8.0.0.4337 at Proactive Defense
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
D+/HIPS = Enabled vis Safe Mode
Autosandbox/BBlocker = Enabled via Default Sandbox Settings
AV = Enabled vis Stateful
Have you made any other changes to the default config? (egs here.):
Firewall Changes:
Create rules for safe applications checked.
Set alert frequency level: LOW
Filter Loopback traffic
Block fragmented IP traffic
Do Protocol Analysis
Enable anti-ARP spoofing
Have you updated (without uninstall) from CIS 5 or CIS6?:
No
if so, have you tried a a a clean reinstall - if not please do?:
N/A
Have you imported a config from a previous version of CIS:
No
if so, have you tried a standard config - if not please do:
N/A
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1, N/A, 64 bit, UAC disabled, Administrator, No
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Avast (was uninstalled, bug still occurs, avast reinstalled) b = MBAM free. (no live protection)

Additional Info:
Specs:

Processor	Intel(R) Core(TM) i5-4670 CPU [at] 3.40GHz
Manufacturer	Intel
Speed	3.4 GHz
Number of Cores	4
CPU ID	BFEBFBFF000306C3
Family	06
Model	3C
Stepping	3
Revision	
Video Card	AMD Radeon HD 7900 Series
Manufacturer	ATI
Chipset	AMD Radeon HD 7900 Series
Dedicated Memory	3.1 GB
Total Memory	4.0 GB
Pixel Shader Version	5.0
Vertex Shader Version	5.0
Hardware T & L	Yes
Vendor ID	1002
Device ID	679A
Plug and Play ID	VEN_1002&DEV_679A&SUBSYS_27731462&REV_00
Driver Version	14.301.1001.0
Memory	8.1 GB
Operating System	Microsoft Windows 8 Professional Edition (build 9200), 64-bit
Service Pack	0
Size	64 Bit
Edition	Professional
Version	6.2.9200
Locale	0409
BIOS	BIOS Date: 07/21/14 11:03:17 Ver: V1.9B0
Version	American Megatrends Inc. V1.9
Manufacturer	American Megatrends Inc.
Date	07/21/14
Display Maximum Resolution	1600 x 900
Sound Device 1	Realtek High Definition Audio
Driver Version	6.0.1.7293
Sound Device 2	AMD High Definition Audio Device
Driver Version	9.0.0.9905
Sound Device 3	Razer Surround Audio Controller
Driver Version	
Sound Device 4	Virtual Audio Cable
Driver Version	
DVD	TSSTcorp CDDVDW SH-224DB
CD	TSSTcorp CDDVDW SH-224DB
Drive	
Size	931.2 GB
Free	513.5 GB
Browsers	
Internet Explorer	11.0.9600.17416
Chrome	39.0.2171.71
Firefox	
Safari	
Software	
Java	7.0.670
Flash	15.0.0.223
DirectX	11.0
.NET	3.5.30729.4926
QuickTime	
Adobe PDF Reader	

[attachment deleted by admin]

Dear progamerzftw

Yes please do edit your first post to make a bug report in standard format, as I will be unable to forward this report without it.

Please append to this report:

  1. A Killswitch screenshot taken while the problem is occuring, showing all processes (indented format) and CPU and RAM columns
  2. If a process is consuming high CPU please dump it by right clicking on the process in Killswitch
  3. A CIS diagnostics file (See help menu in CIS)
  4. An export of your CIS config file.

Many thanks in anticipation. Kind regards.

Mouse

As there has been no reply, I will move this report to “Resolved/Outdated Issues” section.

Thank you.

Sorry, was busy for the past couple weeks, may I still update this post still? :stuck_out_tongue:

Moved for further processing.

Thanks.

Alright, also quick question before I reformat the post. I uninstalled COMODO, so do I need to reinstall it and wait for the bug to occur again before I do a diagnostic report? or can I do a diagnostic report as soon as I install COMODO again.

After the first system restart should be fine.

Thanks.

OP updated.

  1. Did you try to reinstall using this guide?

  2. Please attach a system information file. (run > msinfo32 > save)

  3. Configure your system like in this guide. Additionally, check here. When your computer system is unresponsive again, force a BSOD on key-press and attach the dump.

  1. Haven’t seen it but I’ve tried many things that was in that thread. Edit: Matter of fact almost exactly. :stuck_out_tongue:

  2. Attached to OP

  3. Configured, but the CrashOnCtrlScroll thing doesn’t seem to be working for me on Windows 8.1 when I press Right Ctrl (hold) + Scroll Lock + Scroll Lock

Hmm… I’m not sure why.
The problem is that devs cannot accept this kind of issues without the mentioned dump.

Try to look around this one— recheck registry keys, change keyboard shortcut, etc. Recheck everything.

Thanks.

I have the exact same problem :

  1. Either at a random time of the day the entire system hangs for like ~10 minutes then the computer runs a little ■■■■■■ so I’ll need to restart.
  2. Randomly unable to browse the internet and opening apps, if I wait it out it will eventually open, but then may stop responding, once again a restart fixes it.

Using Comodo firewall 7.0.317799.4142 on Windows 8 x64 ( uac disabled, administrator ) and the only other security software I use is Sandboxie the latest version.

Problem solved by disabling of HIPS and Viruscope ( not sure which one of the two is the culprit ).

Hi progamerzftw

I’m very sorry but we really do need a dump to diagnose this sort of issue.

I will move to non-format incomplete for a moment, as this seems not to be possible on your system.

However it may be possible to do this in powershell: http://www.wikihow.com/Force-a-Blue-Screen-in-Windows

If you can do it please post a link to the zipped dump and the mods will forward this report for processing.

Kind regards

Mouse1