Comodo Firewall breaks Windows 10 Disable display scaling on high DPI settings

For those of us with high DPI settings, we experience many applications that don’t properly support high DPI and are thus very blurry. The fix is to the application exes properties, go to compatibility tab, and check the “Disable display scaling on high DPI settings” checkbox.

After installing Comodo Firewall, this settings fails to have the desired effect on all applications system wide. Removing Comodo firewall restored the correct behavior.

I just had installed the latest version, with a shiny compatible with Windows 10 graphic.

I’m not the only one whose seen this:

I have the same problem


this is a big problem
comodo firewall, is incompatible with windows 10! already 1 october!!!

If I recall correctly it has been reported as a bug. So Comodo should be aware of it.

ok… hope soon to fix this bug…
I can only add that Сomodo 9 Beta also uncompatible with Win10

You mean with high DPI settings?

yes, I mean high-DPI settings.
I installed Comodo 9 Beta and was the same result as with Comodo 8.2 (Internet Security or only Firewall or only Antitvirus - was the same result)

(Sorry for my bad english)

It is not an official beta but a leaked alpha build. :wink: Please wait for the official beta to be released and see if the problem is fixed or not. If not please report it then.

Is there any solution for this issue? Maybe some CIS settings or disabling some components?

where finally official beta? I can not wait anymore. I forced to remove this mess (=COMODO). HDPI does not work in many applications: Corel X7, Inkscape, wise 365, spotify app, steam…
steam and spotify - indifferently, but graphic editors have a terrible appearance
Comodo work with HDPI only in Comodo. And YES - for Comodo you must also set HDPI, without HDPI interface of Comodo is the same shit as by Corel or Ikscape! (:AGY)

There is no date yet for the beta release of v9.

much time has passed and problem still exists … have to uninstall
(CNY) - really ?

  • when I unplug charger from the laptop, then disappears icon of Comodo in the system tray… in Task Manager disappears process CisTray.exe
    I have every time manually launch Comodo, when I unplug charger from the laptop. This bug also since the summer, since I installed Windows 10

Windows 10 Anniversary Update + Comodo 8 (or Comodo 10 Beta) = HDPI not work