Comodo firewall blocks traffic when I don't want it to

Hi there

I edited the predefined firewall policies ‘‘Trusted Applications’’ to have full access to the internet (IP in/out, TCP or UDP in/out and ICMP in/out all requests).

uTorrent is one of the applications that I have configured as a trusted application but Comodo keeps blocking TCP and UDP connections and bloats up the log file with intrusion alerts

Here are my global rules (they where automatically created when I used the stealth port wizard and asked it to block all ports and make me invisble to everyone):

Allow IP out
Allow ICMP in when ICMP messege is Fragmentation Exceeded
Allow ICMP in when ICMP messege is Time exceeded
Block IP in

You need to open uTorrent options and select one port for listening and disable randomize ports.
Pick a Port between say 25000 and 65000 to avoid any possible conflicts.
Then in Comodo firewall Global rules.
select Add and make a rule to Allow TCP/UDP IN from any IP any Port to your IP or MAC and your port you set in uTorrent.

Then move your new uTorrent rule up one time so it’s just above your Block all rule.


Thx for the reply Bad Frogger!

One thing though… if I make a global rule to allow TCP/UDP IN in my selected uTorrent port, won’t I be exposing my PC to that port? Or will comodo only allow the applications that I have permitted to use TCP/UDP IN/Out be able to go trough?

That Global rule will let uTorrent function properly by allowing peers to connect and negotiate
for the exchange of torrent pieces.

Only an app that is set to listen on that port can use it.
If uTorrent is running the port is open, but only traffic that uTorrent responds to is allowed, because of your Application rules.
When you close uTorrent the firewall effectively blocks the port, as with no application “listening”. So the firewall blocks in the log will show as Windows Operating System.


About that, I’m getting a hefty amount of intrusion alerts in my log with ‘‘Windows Operating System’’ whenever I use a P2P program, this is normal right?

I updated my P2P programas (uTorrent, emule and Frostwire) with these application rules:

I just changed the port for each application

But still I get a steady amount of alerts with ‘‘Windows Operating System’’

Any way I can disable the logging of these items, they get in the way when it comes to checking the log for real threats