Comodo Firewall blocks incoming LAN traffic

i have configured a mini lan
with comodo installed on pc1 =
and another firewall on pc2 =
both are running XP SP3

  • i have configured global- and applications rules for the lan (allowing IN/OUT traffic inside the zone)
  • defense+ is turned off (the slider is all the way at the bottom)
  • ping works in both directions !
  • pc1 can access pc2 (=comodo lets traffic pass out)
  • but whenever pc2 tries to read from pc1
    comodo blocks it and there’s a log entry like the following one:

Windows Operating System Blocked 1235 80 TCP


  1. what am i doing wrong ?
  2. could disabling “Block Fragmented IP datagrams” help ? why ?

Thanks in advance


Can you show us screenshots of your Global Rules and the firewall logs?

Have you ever tried other port instead of port 80?


  • the windows explorer of the other pc2 is using port 80
  • pc2 sees a public folder on pc1 (comodo allows that)
  • but when trying to open/read the folder content an error occurs (on pc2)

here are the screenshots… (hope this works)

Global Options basically say:

  • Allow all outgoing traffic thats directed to “My LAN”
  • Allow all incoming traffic thats coming from “My LAN”

Error message (on other PC in LAN) says:
“ is not accessible. You might not have permission
to use this network resource. Contact the administrator of this server
to find out if you have access permissions.
Not enough server storage is available to process this command.”

Thanks !

If your Windows sharing settings are right, have you tried it with Training Mode?
(right permission, not password protected)

Do you have the corresponding LAN rules set up for “System” in Application Rules?

  • oh, thanks, will have to try “Training Mode”
  • but isnt it possible to find out which rule resulted in a log-entry ???

Your Global Rules look good. I think it is a Windows setting regarding network shares… not my forté so to speak… :frowning:

Hello Bottom.

ping works in both directions !

The fact that ping works, proves you have basic conectivity.

have you tried opening a command prompt and typing Netview? This will identify if NetBIOS connectivity is also present.

- pc1 can access pc2 (=comodo lets traffic pass out) - but whenever pc2 tries to read from pc1

How are you accessing each PC?

Windows Operating System Blocked 1235 80 TCP

This suggests you are trying to access a web server running on one of the PC’s. Is this what you wish to achieve or do you just want file and printer sharing?

  • Netview ? i don’t seem to have that installed…
  • i just use windows explorer to access a shared (and visible) folder.
  • i’m just interested in file/printer sharing, don’t know why win-explorer tries to use Port 80 !

Hi, if you don’t have a web server, then I guess your connection is using WebDAV, hence th reason we’re seeing the connection being attempted on port 80.

The Net commands are more or less standard in all windows versions. If you open a command prompt and type net ? you will get a list of available commands.

If you know the name of the server your wish to connect to and the name of the shared folder, Try this.

Open a command prompt and type:

net use x: “http://server/folder” /User:UserName Password

You couldalso try connecting using a stand UNC path:

net use x: //server/folder /User:UserName Password

x would be which ever drive letter you wish to assign to this connection
server is the name of the computer you’re trying to connect to
folder is the name of the shared folder (the shared name)
Username and password are the credentials appropriate for accessing resources on the PC.

Thanks for Your help !
Problem solved - Comodo wasn’t doin anything wrong…

calling “net use” with the unc path gave me “System Error 1130”
and the same message when trying to connect via Win Explorer:
“Not enough server storage is available to process this command.”

Solution was:

Thanks to all for helping !


Hi there…

I’m having a same problem here. I have more than three pc’s which running comodo firewall (all of them) at my office.

I used my notebook (installed with comodo firewall too) once at my office but it could not connect to all of the pc’s. I wonder because of comodo. Then I found this topic here.

Well, it’s all the same. My PC’s are accessing port 80 of my laptop (viewed with firewall event, its the windows operating system process too). I usually use RUN command and type “\server\folder name” to access other computer.

Nothing wrong with local area network at my office. All PC’s are accessible between them, but when my laptop join the LAN, it’s became hidden.

Btw, editing the registry doesn’t work. I’ve tried to use the net command but I’m sorry for being novice at computer, I don’t understand at all. Well, please answer if anyone could give any solution.

Thx in advance.