comodo firewall blocking windows media play to tv (dnla) after april update!

:o
I have Comodo firewall on 4 computers but the April update has caused me noting but grief.
Pc1 workstation- Comodo is now blocking windows media player plat to TV (dnla)
Turn Comodo firewall off and it is ok, although it is in my network zone
Pc2 Comodo firewall is now blocking LCD studio from communicating with winamp although rule defined!
Everything was working ok until update
Pc 3 computer totally crashed on Comodo update messing up system restore and had to reinstall windows 8.1
I do not know what has happened with you newest update but is has caused me issues
I really need play to as I use it to play films for my children while working. But having to now turn off firewall in order to achieve this is not good.
I hope this issue can be resolved. The only common denominator is update
Pc4 total crash. Took Comodo off and all good.
I believe training mode is broken as it does not make a difference and still block window media player play to service although rule is setup!

[attachment deleted by admin]

From what version did you update? If you updated from v5 or v6 your old configuration will not be active. In the update process your old configuration was saved with an applicable name in Manage My configurations.

See if it is there and activate it again.

as i mentioned earlier,the rule has been set. but regardless it still blocks wmpdmc.exe

[attachment deleted by admin]

Can you show a screenshot of your Global Rules and Firewall logs? That may help to get a better understanding of your situation.

done

[attachment deleted by admin]

Could you show a bigger image of the Firewall Events? I need to see IP addresses to better understand what is going on. When they are public IP addresses you can mask them. If they are local addresses (in the 10 or 192.168 range) I need to see them.

ok done
My setup is
1 htpc
1 workstation ( the pc in question. i use this for media player play to . files kept on whs2011 (nas) whilw working. windows 8.1
1 dvr (bedroom)
1 whs 2011 server with all media kept and media shows up in all the computers
I have a home network not home group

[attachment deleted by admin]

Any News. the only way is turn firewall off run play to tv (vera), then enable firewall while film is streaming . it will work but sometimes stops . if firewall is left off, then all good.
I have used comodo for years but this last couple of month when it updated month it is really buggy!

It seems like there is no trigger for a listening executable. I want to see if when we make a specific rule for svchost.exe we can get it to work. I want svchost.exe to ask and log incoming TCP traffic on port 2869.

Go to Application Rules under Firewall Settings. Make a new rule for svchost.exe. Start with copying the Outgoing Only policy. Then add the following rule:
Action: Ask and log
Protocol: TCP and UDP
Direction: IN
Description:

Source address: Any
Destination address: Any
Source port: Any
Destination Port: 2869

See attached image for further reference.

I want to know if you will get alerts from svchost.exe for traffic at TCP 2869. If so does this fix it?

[attachment deleted by admin]

i get file no supported, but if i disable firewall, it works. My media is kept on server but mapped to show all computerson network including on workstation.home

[attachment deleted by admin]

Could you try making a rule for svchost.exe like I suggested to see if that triggers an alert?

yes i did and it did not ask, somesomehow when workststion tries to play from server to tv , it blocks it although ther are all on same defined network.
and now with svchost.exe defined, get a new error “media not supported”
I wish i did not update comodo now >:(

[attachment deleted by admin]

One question. Is the custom rule you made for svchost.exe somewhere above the rule for Windows System Applications ? That is mandatory for the rule to work because rules get read top down.

Another angle could be to give WMPDMC.exe an ask all incoming and outgoing rule to see if traffic may be gets blocked by the current application policy.

A next step would be to import and activate a factory default configuration and see what happens when we use that as a foundation. It helps to see if the update accidentally broke your configuration. When importing give it an applicable name like CIS Proactive Security New or so.