Comodo firewall/Avast Anti-virus

My version of Avast Anti-virus was recently up-graded to the lastest version with all necessayr updates. 4 separate boxes came up saying the Avast Mail Scanner will not be able to protect ingoing and outgoing mail (SMTP,POP3, and IMAP protocol). It also said to check my personal firewall (which is the current version of Comodo) to make sure "ashMaiSv.exe is not blocked. In the “application monitor”, it is marked ALLOW. I don’t know what’s up. Does this mean ingoing/outgoing e-mail? Is it safe to check e-mail? Thanks for any help you can provide.

For starters…
Try right clicking on the avast system tray and selecting “stop on-access protection”.
Acknowledge the warning and once it has stopped all the providers, right click and select “start on-access protection”.
Comodo firewall should warn you that the avast files have changed, select “remember” and “allow”.

If this doesn’t work let us know there are a couple more things to try.

I did everything you said, however nothing came up from Comodo when i clicked “start on-access protection”. On the Avast main window, under “on access scanner” and under “internet mail”, it says “provider is currently running”, and i have the sensitivity set on high. I haven’t had any problems with e-mail, nor any viruses, but i still wonder why the warning messages came up.

Solved this problem several months ago and have encountered this problem on several other comps since then. i’d suggest you try again. I think you did not get the services shut down. i’ll reiterate for Moto:
Right-click on the avast icon and select “stop provider”. Select the service that triggers the offending message. Select “no” at the next prompt(non-persistent change). Repeat for all relevant services.
Next, left click on the avast icon and restart all your services that have been shut down. You should get response from Comodo then.

I stopped/terminated everything you said: SMTP,IMAP and POP3, then re-started them, but still nothing from comodo. For the Avast on-access scanner installed providers: instant messaging, internet mail, network shield, outlook/exchange, P2P shield, standard shield and web shield, all say
the provider is currently running except for “outlook/exchange” which states “provider is waiting for a subsystem to start”. I do not use outlook, but i have received a couple e-mails w/attachments which outlook needed to open. Maybe i’m just worrying about nothing, i just don’t like taking chances when warnings come up. I googled the warnings, so i understand what the protocols are.

If the internet mail shield is now running, then you will now be protected for smtp,imap and pop3.
The outlook/exchange shield will only start when Outlook is running.

After you reboot do you still get the original message warning about lack of protection?
If not, double check by hovering over the avast icon and it should say “7 providers total, 6 running”.

If you have less providers running, it may be because you have accidentally turned them off.
When you stop and start the shields from within the “on-access control protection”, then it prompts if you want this setting to persist. It is easy to misread this as an “are you sure” prompt. To re-enable any that are not running (with the exception of outlook/exchange), then restart them from within “on-access control protection” and select yes to persist.

If you are still having problems…

  • Stop the services again, by right clicking on the avast systray icon and selecting “stop on-access protection”.
  • Acknowledge the warning
  • From within task manager kill the “ashdisp.exe” process (this is the systray icon)
  • In the services control panel, stop any avast services that are still running (should just be “avast! antivirus”)
  • Restart the “avast! antivirus” service
  • Browse to your avast install folder and run the ashdisp.exe
  • check that 6 providers are running by hovering over the icon again

You will probably be prompted by comodo about new parent applications for the avast processes.

Reboot and check that 6 providers are running.

There are 7 providers, 6 running. Mainly, the only time the warnings come up is when updates are downloaded and installed. After i followed the above advice, there were only 5 providers running, i didn’t do anything, then 6 were running.


with AV programs, it is generally true that for their various modules (such as email scanner) you need to edit the the Application Monitor rule in CFP, go to the Miscellaneous tab, and check the box, “Skip Advanced Security Checks.” This will ease their ability to connect and do their job.

That may help you.


  1. Opened CFP
  2. Clicked on “Application Monitor”
  3. Both with and without my glasses, could not find the misc tab until i clicked on “Advanced”.
  4. Clicked “Advanced”, then clicked on “Misc”, but still could not find the tab “Skip advanced security checks”.
    The only things i found that did say “skip” was "skip loopback (127.x.x.x) UDP connections, and "skip loopback (127.x.x.x) TCP connections. The UDP is checked, the TCP is not.

Hi lynyrd44.

To clarify LMs post, in Application Monitor double-click each Avast listing, click the Miscellaneous tab and you will see the “Skip advanced security checks” box.

Hope it helps. (V)

Tnx Jahn; sorry lynyrd44. I should have been more clear in my instruction.

Now that you know where to go and what to do when you get there, give that a shot and see if it helps.


Thanks much for the help and info. Finally got there, and did it. Like i said above, the only time the warnings came up was for update download/install. Will see what happens next time, hopefully, nothing. Thanks again!!!

Sure thing. Keep us posted!