Comodo firewall and Wireless net.

Hi , I have installed Comodo Firewall in my LAN network but sometimes I connect with my laptop through a neighbor wireless net. Since I installed Comodo the wireless net is available but I can not connect to it, maybe it is sort of trusting the wireless net but do not know how to do this, help will be very appreciated.

Thor Hedderich

You need to add a trusted IP address for that wireless network. Goto Security>>>Tasks and click Add/Remove Modify Zone . Then click add and add 192.168.1.1 to 192.168.1.1 and click ok and ok again. then click on Define a new trusted network and select the one you’ve just added using the drop down and then click next and click finish. Reboot and connect to your neibours wireless.

That should do it!

I had a similar problem but I can’t get it to work. I have two interfaces: LAN and WLAN. The one that I had no problems with is my LAN but my WLAN, I can detect it (SSID displayed) but I can’t get get the connection up. Keep telling me “not connected”. I’d uninstalled Comodo but still can’t get it up. I tried doing what the previous post suggested but still nothing. I’d even uninstall my wireless driver and reinstall it, zilch.

I uninstalled PCTools Firewall (no problems with that one) and installed Comodo Firewall Pro and first thing I noticed was the wireless had connection problem. All my other colleagues have no problems (they are using Windows XP built-in firewall).

My SSID is hidden (not broadcasting out wondering if this is a problem) but I can’t seem to get it up. I’ve looked at the Logs (from Activity/Logs) but nothing is blocked.

So I’m just wondering if it’s a bug or could I configure Comodo to monitor on my LAN interface only and leaving Windows XP built-in firewall to monitor my WLAN?

Additional note: I need to use my LAN to connect to a semi-trusted zone and my wireless to access to another zone. These two zones (by management decision) should not be able to communicate with each other (i.e. not routable). DHCP is enabled on my WLAN but my LAN is static.

Unless you have permission to connect through your neighbors wireless network and use their internet, this thread is very close to being locked.

Am I being penalized for something? I can assure you that I have the rights to go into both LAN and WLAN.

My wireless was fine earlier, getting IP address of 172.31.x.y and I do not have a problem with my LAN too (since it’s static).

All I’m asking if you could show me how to have Comodo to monitor my LAN interface and not my WLAN interface.

Sorry, my previous comment was directed at the OP.

Not you :■■■■

Is the wireless network still in your Wireless Connection List? Has your neighbour changed the WEP or WPA key? I trust your smart enough to be connecting over a secured network? Try removing the item from your Wireless Connections list ( The one where you click on wireless connection and then click on properties. Try re-adding it. Might be useful to get your neighbour to temporarily display the SSID.

PC Tools has been know to interfear with wireless connections at least that’s what I’ve heard. As long as the network address of the Wireless Router you are connecting to is set as “Trusted Zone” in comodo you shouldn’t have any problems. have you tried uninstalling comodo, reactivating Windows Firewall, connect to the network and then re-install Comodo. Are you connecting with a Fixed IP address? There are so many variables with regards to this. Your best bet is to get what information you can from your neighbour. Make sure that his Router has your Machine in it’s MAC Address List.

Anyway… Maybe I’ve confused things here…

Eric

Someone suggested that I update my wireless driver and so I did. Went to the Intel website and downloaded the new driver. Working now. Thanks for the effort though.

Hmm, I seem to be stuck on this one too. I have CPF version 2.4.18.184 which is otherwise working fine.

I have a zone Intel(R) PRO/Wireless 2200BG Network Connection - Packet Scheduler Miniport - to allow me to surf wirelessly with this laptop (192.168.0.0-255).

On the laptop, I’ve created an adhoc wireless network for home use (Open, WEP encrypted). This set up works when Windows Firewall is switched on (and CPF set to Allow All). However when I switch CPF on (and WinFW off), it allows devices to connect (eg Nokia N80, other laptop) it allows the network to be found, and opens the connection, but allows no traffic whatsover. Switch firewalls back to WinFWon and CPFoff, all is working. When I start with WinFWon & CPFoff, open a connection, keep the connection whilst switching on CPF, the connection and traffic can successfully continue and is maintained until that connection ends.

This is occurring with both internet and non-internet connections (Salling Clicker, which can remote control iTunes & other apps with a mobile phone via wifi +/bluetooth)

Hiya dougalzene,
Firstly you need to Add the IP address of your router in the Trusted Zone. This is done by Security>>>Tasks “add/remove trusted zone” and then clicking on “Define a new trusted network” and reboot that should allow all communication between your router and the laptop.

Secondly, you need to better secure your Wireless Router. WEP is extremely easy to ■■■■■ so read the “Securing your wireless network” post in the FAQs and follow the instructions. You should at least be on WPA-PSK encryption for your wireless network as well as having MAC address filtering and it’s hardware firewall turned on.

Thirdly, you need to update your 2200BG wireless driver! Here’s the website:

http://downloadcenter.intel.com/Product_Filter.aspx?ProductID=1637

The current version of CPF ony has connection problems if your computer goes into hibernation. The quickest way to resolve the issue when it occurs is to log off your computer and log back on again.

Eric

Wow! Thanks for this little gem of a notation, Eric…I was having this problem and thought it was just a “Windows’ thang”. And, I was getting around it just as you suggested, relogging. I hibernate all my 'puters instead of shutting down - that only happens when I need to make an Acronis backup.

Thanks Eric.

  1. This setup does not include a router - it is a computer-computer/adhoc network.
    There is a Win laptop with CPF and Intel Wireless 2200BG. Nokia N80 is main device that connects to the laptop to access the internet and communicate wirelessly with laptop (salling clicker, also home network for sharing files). From an operational point of view, all works well with CPFW off and Windows FW on.
  2. As far as I can see the N80 does not support WPA-PSK encryption. Is the firewall preventing access based on the level of encryption? I am not concerned about the ease of cracking. Trust me the environment and location is such that it is not a concern.
  3. Have updated both the drivers and utilities to the most recent.

If I switch Windows FW on, CPFW off, the connection is opened and traffic is allowed. If I then turn CPFW on, traffic is still allowed. If however the connection is opened with CPFW switched on (and Windows FW off), no traffic whatsoever is allowed. In all cases, the wireless network is shown as connected and signal is excellent.

I have tried to switch off at least all programs that connect to the internet before trying again and logging. I have logged a couple of events - maybe they can tell you more than they tell me!

[attachment deleted by admin]

Still nothing,
I have followed the steps ading a new trusted network and still I am not able to connect to our neighborhood wireless net, when I had McAfee firewall I had no problem, just turn the wifi switch on and locate the network with the config free software included in the Toshiba and voila I was able to connect to the web without messing around. Now I am stuck with Comodo and do not know what to try next. The wireless network is public and do not need any permission or password to connect to it. It is a free service offered by the neighbor association. By the way I have a wired LAN connection but when I go autside my home I simply connected to the wireless network and thats all.
I would appreciatte if posible a detailed step by step instructions on how to connect to this net. Also the net is unsecured and the signal is very strong.

Thanks in advance,

Thor Hedderich

Hi, I’ve just started using Comodo after my pc got infected and I didn’t trust Norton and sometimes my internet disconnects, this usually happens, but when it tries to reconnect it gets stuck on “Acquiring Network Address”. I tried again when I disabled Comodo and it worked. How do I allow my Router to connect without being blocked by Comodo Firewall? I’ve tried all your suggestions. I am connected with a BUFFALO WBMR-G54 on LAN. I have allowed my network and such. It’s just irritating when it disconnects in the middle of games and I have to fiddle with it to get it back on.

If this is not classed as relevant then I’m fine with that, just wondering.
Thanks
(V) (CLY) :BNC
cheers.

Well I have also follow all the recommended steps and still nothing, I have sent a mail directly to support and hope the will instruct me an how to solve this “un-connection” issue. Maybe next version could solve it. Still waiting and using my cable connection.

Regards,

Thor Hedderich

Teeh, if you right-click on the Comodo firewall icon, down on the right in the system tray, and then choose “Adjust security level” then choose “Allow All” does this allow you to connect to the wireless network?

jasper

Hi have done that and it worked, it connected to the wireless network so I presume it is a Comodo issue or misconfiguration. What next?

Regards,

Thor Hedderich

Me too - this is how I get this to work when I need to - although it is a manual procedure and I’d prefer to resolve it.

I switch to Windows Firewall and then set Comodo to Allow All and it allows devices to connect and pass traffic. To reiterate what I already mentioned earlier, if I then switch Comodo back onto my custom config, it still allows the traffic to pass on the still-existing connection but of course it will not work on next re-connect.

Obviously it’s good to know Comodo is covering my back but I just can’t figure out how to have Comodo allow traffic on my adhoc wireless network.

Ok, let’s try this.

Clear your firewall log by right-clicking on the Logs window and choosing “Clear All Logs”.
With the firewall set to “Custom” try and connect again to the wireless network.
Right click on the log again and choose “Export HTML” then save it as a .txt file and post that text file here using “Additional Options” below the text window when you are posting. If you could also post a screenshot of your Network Monitor rules, hiding any IP addresses that you don’t want viewed publicly, then that would be great too.

Try that and we’ll have a look at to see if something sticks out that might point to what the problem could be.

dougalzene, if you could do the same then either myself or someone else will be glad to try and help you out.

It’s going to be about an hour or so before I can post back so stick with me here. I haven’t forgotten you.

jasper

If I close all PC internet apps (Opera, Skype, Gmail notifier…), clear the logs, then run through the connection attempt - there is no log!

Attached is a screenshot of the network rule. Off screen for 1&2 is the IP range of the wireless zone 192.168.0.0/255

[attachment deleted by admin]