Comodo Firewall and Windows Update

After installing Comodo Firewall v2.3.5.62 and AntiVirus v1.1.0.3 no Microsoft Update is working. Everytime I try to update it gives me an error saying:

“An error has occurred while copying file . Cannot copy file to destination directory.”

For every update the filename is different. I checked your forums but they do not show anything for the new updates only for older versions.

I have restarted my computer and tried the updates again but the errors keep coming up…

Is there any fix out there to solve this problem?

Thank You.


  • Please Navigate to “Activity” - “Logs” and paste us your logs, let’s see what CPF is blocking

  • Take a screen shot of your Network Rules, let’s see what you got


I looked at my logs I believe that svchost.exe is being blocked when running the updates. But under application control rules svchost.exe is allowed.

[attachment deleted by admin]

The problem will be that either services.exe or svhost.exe or System is blocked in your application list. (as you can tell, i’m going from memory, but it will be one of those)


  1. Log Analysis:
  • Add your LAN on the Trusted Zone(Security - Task - Define a New Trusted Network)

  • Navigate to Security - Application Monitor - and delete all Rules you’ve created for “svchost.exe” , “services.exe” , “system”

  1. Make sure you’re not Online when applying Method1 suggested above.

  2. Reboot Immediately

  3. Connect to the net and you will get those pop ups again. “Allow & Let it remember”

  4. If any error occurs, please repaste back your new logs.

       When replying back, please do take a screen-shot of your current Rules. I'm curious on what you have as your Rule #5, since it's blocking Outgoing ICMP/UDP connections.


Just to be sure it is Comodo causing the problem. Did you try to run Windows Update with Comodo in the “Allow all” security mode?

Well I tried both allow all and disable the firewall from protecting my computer and nothign works…

But then im running into another problem this Windows Update issue, it was working fine before I installed Comodo Firewall and AntiVirus…


Maybe the AntiVirus is causing an issue…

Im gonna have to check this out…