Comodo Firewall and System Restore


I’d like to install the free Comodo Firewall when my Zone Alarm Internet Security subscription expires very soon. The Zone Alarm led to various system restore failures.

At first I was considering installing both the Comodo Antivirus as well as the Comodo Firewall, possibly in the form of the Comodo Internet Security. but I read some posts here of similar system restore failures with the CIS:

That thread goes back several months, so I’m hesitant to add my question to that thread above.


Are the System Restore issues with Comodo limited to those who use the Comodo Antivirus or Comodo Internet Security?

Do those who use the Comodo Firewall as a standalone experience similar issues with System Restore?

Thanks in advance:


Windows XP Professional Edition
Dell Optiplex GX 260

As long as you don’t install the antivirus you’ll be fine. It’s the file C:\Windows\system32\drivers\sfi.dat, which is installed with the AV that messes up system restore.

The tricky bit is that not every user is affected.

You mention that you are using XP Pro SP3. That is what I am using and I have no problems with System Restore. There are other users that have reported the same thing. So there is obviously more to it than just the sfi.dat file.

I would say install the whole suite and see if you happen to have the issue. If you do, you can try running the AV in on-access mode instead of stateful. Stateful mode is what utilizes the sfi.dat (SFI stands for Stateful File Inspection) file. I run stateful, and as I mentioned, I have no problems. If that still doesn’t work, uninstall the AV and install Avira or Avast. Both work well with CIS’s firewall and D+.

There is a quick way to test if system restore is working for you.

  • Create a restore point.
  • Create a shortcut on your desktop. (The shortcut can be anything, this is just a test)
  • Restore your computer to the previously created restore point.
  • Shortcut will be gone if System Restore was successful.

Thanks for your detailed answer, Heffe:

I might be at 'higher risk" for system restore problems, since I experience those with several versions of Zone Alarm which I’ve been using recently.


1) How easy is it to uninstall just the AV component of CIS if such problems should arise?

Isn’t there a Defense+ component in the CIS as well? Can that component be readily uninstalled?

2) Would you perhaps know if the Comodo Firewall+NOD32 Antivirus combination might work out in terms of this issue. I’m told the NOD32 is among the best AV’s.

Thanks again:


Windows XP Professional Edition

After you install CIS, you can just go to Start → Programs → Comodo → Comodo Internet Security and select Uninstall or Upgrade. This will start the wizard and you can use the Add/Remove feature to uninstall the AV.

Defense+ is installed with the firewall. This can be disabled at any time. You can also disable it permanently, which requires a reboot.

I’ve never used NOD32, but I don’t see why there would be a problem. If you’re interested in reading it, there are some users in the compatibility thread that say they have no issues with CIS and NOD32. How Compatible CIS is With Other Security Products: Your Opinion Needed


I have recently had system restore failures on both my desktop and laptop which I suspect is down to the Comodo firewall, since it’s the only common installation to both machines likely to cause such problems. The desktop restored to blank wall paper with no icons and was totally unresponsive. I had to undo the restoration via safe mode.
The laptop appeared to restore ok despite an announcement en route that a file pertaining to the touchpad couldn’t be found and Comodo had discovered a “new” wireless network. However I was unable to reach any websites despite an active connection - it continually timed out. I undid the restore which seems to have been successful, although a message did appear just before the wallpaper arrived stating I did not have administrator rights to perform a restore.

Is there a way around this deadly feature of Comodo? System restore is such a valuable facility that I don’t want it jeopardized, but I’m loath to uninstall the firewall which in every other way is brilliant.

I’m running Avast free AV alongside with XP S3 on both machines. Thanks :-\

Just a quick clarification of what I have found. The sfi.dat problem with system restore and the fact that it could not be defragged, only applies to the 3.xx versions of CIS. In version 4 it seems you can access the file normally.

Would that mean that in CIS Version 4 there should be no problems with System Restore?

I’m also somewhat disheartened by debroos post above, wherein the Comodo Firewall alone seems to be the culprit.

Anyone else find this?

I don’t know if version 4 has issues with system restore. I’m not using version 4 yet. And since I don’t have the problem with version 3.14, I don’t think I’d have the problem with version 4 either.

The culprit is the sfi.dat file which is installed with the AV. The firewall doesn’t need the sfi.dat file. I suspect debroos has something else entirely going on.

Thanks for observations HeffeD

I managed to restore back a couple of weeks to comodo V3 and replaced Avast with Windows security - reinstalled Comodo 4 and I’ve done several restore checks and all seems ok. I suspect some kind of registry corruption - cause unknown - must have created the problem. ;D

System restore does not work on my windows 7 64bit computer using CIS version 4 or my girlfriends vista 32bit laptop. However I am pretty sure system restore works if your run it in safe mode, Although you cannot undo the restoration if you ran it in safe mode.


How do you mean? You don’t get the option after applying System Restore? Or do you mean you can not manually choose to go to the situation you started from?

Hi Shaun:

I wonder if it might work in Normal Mode as well, if you disable the AV and/or Firewall while running the restore.

I haven’t installed CIS yet, so I cant test this

When running the restore (on windows 7 at least) it states that running windows restore in safe mode will not let you undo the restoration, i guess via either method.

Disabling the AV or changing it to on access etc doesn’t resolve the issue.


Hi debroos:

You mention that you replaced Avast with Windows Security. I wonder if it wasn’t the Avast which created the problem with system restore in the first place. Rather than the Comodo firewall. This article describes that glitch and how to prevent it:

I came across it because I’m looking for an AV which won’t interfere with System Restore -as well as a firewall.

That post was from May 2008 and says the following:

There are two simple methods to get rid of this problem: either you download the latest version of the application (which, by the way, was released today for both Home and Professional editions) or you disable the Avast self-protection
"There are two simple methods to get rid of this problem: either you download the latest version of the application (which, by the way, was released today for both Home and Professional editions) or you disable the Avast self-protection"

Thanks Eric.

But that same problem is described by Avast users last month, so apparently that upgrade didn’t completely resolve this issue.

Thanks for that Eliuri

I suspect it may have been Avast. Since uninstalling it I have checked the restore function on both of my machines and they work ok. The Microsoft Security Essentials has fairly good reports and seems ok at the minute. I may give Avast another go at some other time with the recommended tweak. :slight_smile:

Thanks debroos:

Curious if it will do the trick for you, as I’m considering that very combo: Comodo Firewall and Avast!

Trying to get as clearer a sense of this before uninstalling my present security suite because of this very issue.

i have never used avast on this comp or my second one or my GF’s and they all had the system restore problem with Comodo.