Comodo Firewall and RDP

I just installed Comodo Firewall (free one) on my Windows 7 RC machine. I have set Network Defense and Proactive Defense to Training Mode. I tried RDP into the machine, and got an error saying that I can’t connect to remote computer. Firewall never asked me if I wanted to block in coming connection, it automatically decided to block it. I can see the blocked actions in Firewall Events (destination port 3389).
Why did it not ask me to allow the connection?

I then went to Network Security Policy, and under Global Rules I made a rule: Allow TCP In/Out Any Source Address, Any Destination Address, Any Source Port, Destination Port 3389.
I moved the rule to the very top.

I still can not RDP into the machine, and the Firewall Events keeps showing blocked connections to 3389 port.

I am lost. Can you help?

Thanks,
RMSe17

Hello RMSe,

A few questions, did you disable the Windows Firewall?
Did you run the Stealth Ports Wizard?

Can you change the global rule from In/Out to In and see if that helps?

Can you make sure RDP is listening by opening a command-box and typing

netstat -an|find /i “3389”

See if the port is listening for incoming traffic ?