Comodo firewall and Mobile Broadband

I created a new topic for this problem since it does not seem to have enough attention.
Problem is this:

  • In Windows 7 comodo firewall does not filter any connections IF i create internet connection using new Mobile Broadband feature of Windows. (Active Connections has only localhost connections)
  • If I create connection using dialup (my 3G modem is like any other modem), comodo firewall works ok.

I have tested this quite a lot. Here I attach some files that will show you that this really is the case.
The way I create connection affects the way firewall filters my connections.
Firewall tests results show that this is really true.

Any ideas? Have you experienced that? Does you 3G connection filtering work ok? Am I alone in this situation? ???

Hardware:

  • THinkpad T500 with internal Ericsson F3507g 3G modem
    Software:
  • Avast 5.0
  • Comodo 4.0.14xxx (latest)
  • bunch of office software

[attachment deleted by admin]

I can confirm this problem.

I am using Windows 7 and a HUAWEI E1550 UMTS Stick. Connections are not filtered. In the device properties the Comodo firewall driver is not listed. Not good.

Interesting. Not an IP firewall expert, but seems like it might be a significant problem.

I would think you might be able work round this by deleting the loopback zone from Network security policy ~ My Network Zones tab, and creating rules by allowing specific application interactions in its stead. Might be difficult to make them target specific though if the OS maps everything via localhost… Hmmm.

Alternatively you could use the free version of Comodo TrustConnect - this might restore your ability to filter internet connections. Have not got Win 7 so cannot test.

Best wishes

Mouse

Maybe difficult, and not os dependent, as a 3G stick is seen by the system as a modem, usb stick, and cd drive.

But what is the issue about phone dialing? Even in 3G broadband, a 3G stick, exactly like a 3G cellphone, has a dedicated phone number and actually dials.

This problem seems to be caused by changes made to Windows 7. It has a feature “Mobile Broadband”. It uses Mobile broadband like WLAN or other network connections. It is clearly a compatibility issue between Comodo and W7. That is for sure.

I can use Mobile Broadband modem as old fashion dialup modem. Then comodo filters connection ok.
But if MB feature used, no connection (especially inbound) are not filtered at all!
It appears that comodo cannot register its filter driver to MB connections.

I just updated my huawei e1550 and the same problem happened to me. Does i have to use dial up every time and shouldn’t choose the mobile broadband to connect?

I can confirm this and it is VERY VERY annoying.
I am using Comodo CIS+ 4.1.1503. It worked very well until I started using a Huwai Broadband USB modem. Whenever I connect using the Win7 “Mobile Broadband Connection” or the Software “MobilePartner” that comes with the modem, Comodo just stops monitoring the network traffic.
To test this I can even set the firewall to “Block All” Mode and in fact I am writing this message while in “Block All” mode!

It is very annoying and suddenly I feel very insecure. At home I use a router, and now abroad in public not behind any router atl all suddenly Comodo fails totally…

I tried to use the modem via Dial-Up to circumvent this problem, but I have to say I couldn’t get it to work. It connects fine (I even set the APN in the modem-advanced settings), I get assigned an IP and DNS servers, but whenever I query an IP or URL it simply times out… Perhaps another user can help me set up my USB stick as dial up?

comodo needs to install the firewall driver in the network connection you have. If you look in network → manage connectiosn and right click on lan and select properties you will see comodo firewall listed. When you are connected through USB you will see that the new network connection does not have it listed. You might have to uninstall comodo and resintall it with the usb modem connected so it can see the usb connection so it can install the firewall driver in it.

Comodo does install filter driver for LAN an WLAN correctly. I have internal 3G modem (Thinkpad T500 and Ericsson F3507g) which is always on and connected - even when I installed comodo. That does not help Comodo. It still can not filter correctly any “Mobile Broadband” connections. If dialup using F3507g, Comodo works ok. MB feature of W7 has some compatibility issues here. Windows Firewall works ok even then.

I think Comodo should look into this problem more carefully. Many users are using MB connection, but they never check whatever their firewall is able to filter any inbound connection. Actually their computer is more vulnerable than if they used W7 own firewall. ???

Yes I can confirm that it is a Windows 7 bug. I am using Win 7 64bit and the Comodo firewall has absolute no effect when used with the USB modem. I am also using Comodo on Win XP 32bit with the same USB modem. There Comodo works perfectly well.

I don’t know what exactly happens in the Win7 broadband feature that Comodo does not work, but as noted before it is definitly a bug and definitly a compatability issue between Comodo and Win7 here!

I indeed hope Comodo can look into this, I always thought it to be one of the best AV/Firewall solutions, but I can’t keep using it when it doesn’t block anything anymore on the USB modem, neither incoming nor outgoing.

It would be nice to have a comment from comodo devs concerning this bug! ???
I think one of us who have posted here is happy to provide assistance to fix this.
But how to contact them?

I have no clue how to contact the developers. I definitly would like to assist in fixing this issue.

I found out, that when looking into my Broadband-Network properties, indeed the Comodo Filter driver is missing. At least for me. I tried manually installing it using the “inspect.inf” file inside the Comodo directory, however the installation can’t complete because after selecting the inspect.inf file I get an empty list of “available” drivers to install in that file :frowning:

I also tried manually updating the Registry settings of the Broadband-Network connection and adding the filter driver there directly, however it didn’t work.

It seems the filter-driver does not work correctly/can’t be installed properly on the Win7 64bit broadband feature. Definitly a bug…

Devs contacted on this and another closely related issue.

Hang in there.

Ewen :slight_smile:

Hi Guys,

We are looking into the issue. We will release a BETA version of CIS 5 this week and hopefully it will fix the issue.

If you can stably reproduce the issue, can you please send me a PM and we can work together over MSN?

Thanks,
Egemen

Apparently issue is present in CIS 5 beta too.

https://forums.comodo.com/beta-corner-cis/comodo-internet-security-501573021066-beta-bug-reports-t60015.0.html;msg423302#msg423302

Slobix has just verified that the issue is fixed. We will issue a BETA tomorrow which should work well.