Comodo Firewall and Live Messenger - NO Connection

Hi therre!

Sorry about my post, i know there are some others.
But my english isnt pretty well, so i had to ask you again.

So … my problem … Today i uninstalled my Sygate Personal Firewall, did a reboot - and installed the comodo Firewall.

Now my problem:

I did all for myself, no automatic configuration.
Why i did? because i dont wanna allow some Windows-Services to access the Net (phone-home).
Thats the first problem, i cant disable Windows-Homephoning? With Sygate i was able to, im confused.

And now the second: I cant use the Windows Live Messenger anymore.
I gave all rights to the msn executalbe (cant remind name for now), but it cant access/conenct.
Its only possible if i disable all application rules (switch the checkbox on OFF).

So i cant use the application rules because my messenger dont works with.
Is there any solution i may understand? I just cant read thoose english shortcuts, im from austria → german.

Thanks anyway, ncie Firewall! Maybe some more Skinsupport for 3rd Party Skins? (V)

greets,
markus

push

Please, im “insecure” … speed on (:WAV)

Okay, so if MSN works by turning Off the Application Monitor, then we know it is an issue of rules within Application Monitor. Will you do the following things, please:

  1. Turn On Application Monitor.
  2. Go to Activity/Logs.
    a. Right-click an entry
    b. Select “Clear all logs.”
  3. Run Live Messenger, try to connect

When it fails,

  1. Open Application Monitor to full-screen size
    a. Click to highlight the MSN Live Msgr entry
    b. Capture a screenshot; save it as an image file and attach to your post using the Additional Options (bold red text right below your post)
  2. Go to Activity/Logs
    a. Right-click an entry
    b. Select “Export to HTML”
    c. Save the file, and re-open it (it will open in your browser)
    d. Highlight the entries for Application Monitor; right-click and Copy
    e. Paste the copied entries into your post here (if for some reason your external/public IP address shows in your logs, you may mask/edit it out with “x”).

This will help us see what is happening, and address it properly.

Thanks,

LM

Awesome, works.
Just cleared the Logs!
Thanks.

Greetings,
Marc

Clearing the logs isn’t going to change the issue at hand, Marc. Wish it were that easy, LOL. That’s just to get us a fresh “board” to start from, so it’s not cluttered with irrelevant entries.

If MSN Live Msgr is working now, and continues to, it may be that you inadvertently blocked it; after a reboot the memory would be cleared and all would be well again. As I understand it, there really shouldn’t be any configuration to do; run MLM, respond Allow with Remember to any alerts from CPF, and you’re all set. I did it myself for another user who was having issues (I don’t do IM as a general rule) and that was all I had to do.

But clearing the logs did not resolve the issue, I can assure you. ;D Let us know if it continues to work, or if it hangs again.

LM

Thanks for the warning.

Just woundering why it happens? I installed the new Beta of the msgr, and it worked well with sygate.

So there are no disabled windows-services, the firewall got problems itself.
You really should fix it.

And allow to block windows-services for expert users! Some kind of services need many many traffic, and i dont got endless of it :frowning:

But for now the problem is served. I just deleted all log entries and changed the language back to english. Then i restarted the firewall and re-enabled the application-rules.

If “all” the comodo software gets more popular and dont lies the users (removing backdoors - HAHA dont lie at here, all others do, change something!) i may will use some bundle of antivirus, firewall, antispyware and so on.

As i got the chance to talk to the developers - change as many you can, make 2 kinds of unterfaces - normally and expert - and never lie at all! If normal users know that experts use the software, they will do too!

greets,
marc

Hi marc

So there are no disabled windows-services, the firewall got problems itself. You really should fix it.

I’m not sure what you’re referring to here, what do you believe needs fixing?

And allow to block windows-services for expert users! Some kind of services need many many traffic, and i dont got endless of it

Which specific services are you thinking about?

make 2 kinds of unterfaces - normally and expert

You really don’t need a separate interface to configure the firewall in ‘expert’ mode. Everything you need is right there. However, you will need to understand how the firewall works, to configure it to your requirements.

Toggie

Hi Toggie!

I'm not sure what you're referring to here, what do you believe needs fixing?

It must be more easy to configure “Applications” like MSN and/or ICQ. As you saw, it didnt worked for me. I had to clear the Logs first. Now it works - even after some reboots. So its a Bug of the Firewall.

Which specific services are you thinking about?

Anything which is automated on Windows and not neccesarry for other applications.
Still thoose Services, which are allowed automaticly on the FW, because it dont asks for.

You really don't need a separate interface to configure the firewall in 'expert' mode. Everything you need is right there. However, you will need to understand how the firewall works, to configure it to your requirements.

Maybe, yes. But its not easy to configure the FW für beginners. So they got many problems with, anyway.

Its a very nice Firewall. Its free, it looks nice, but its still hard to configure.
Wish there were more Help-Topics inside the application (noone uses the helpfiles!).

greets,
marc

Wish there were more Help-Topics inside the application (noone uses the helpfiles!).
Hmm, that might be good to add to the WishList (you can find it from the main Firewall Board, under Feedback); sorry I don't have a link handy on this machine.

As for the beginner’s setup, you can find a “set & forget” tutorial in the FAQ (or in the Tutorials Compilation thread in the FAQ).

Inasfar as not allowing services to run, that’s easy as well. Under Advanced/Security/Miscellaneous, uncheck the 2nd box, “Do not show alerts for applications certified by Comodo.” OK. This will give you a lot of alerts, because as we all know, Windows likes to talk… :wink: AFAIK, for the average user who is not networking (and maybe even if they are), the only service that really needs access is svchost.exe (as the application), with services (or maybe it’s system; I can’t remember at the moment) as the parent. This is necessary for your connectivity.

LM

PS: Once again, I guarantee you that clearing your logs did not do anything to resolve your issue with MSN Live Messenger, nor are any special rules necessary. My bet is that you had inadvertently blocked it and didn’t realize it. At some point, possibly through a reboot, or closing/reopening the firewall, you thus removed the temporary block, and connectivity was allowed.

Hi marc.

So its a Bug of the Firewall.

To be honest, it’s a configuration issue as opposed to a bug.

Anything which is automated on Windows and not neccesarry for other applications. Still thoose Services, which are allowed automaticly on the FW, because it dont asks for.

As LM said, there is only one Windows Service that requires Internet access and that is svchost.exe with a parent of services.exe. This service performs a number of essential functions, such as IP Address acquisition (DHCP), DNS Name queries, Windows Updates etc.

Also, don’t forget, unless you specifically create a rule in Application Monitor, to Allow a specific service, it will be DENIED by implication.

Toggie