Comodo Firewall and Avira Anti-Virus,

I had tried three separate installs of Comodo CIS and every time got problems with the AV part. Problems such as the 30% stall but the main one was that sooner or later when I rebooted my PC the AV database would revert from the latest version to version 1157 and I would spend an hour or so getting it up to date again only for it to happen again after a new reboot of my PC. I decided to uninstall CIS and reinstall just the Firewall and Defence + set at the highest Pro-active level and install Avira as an AV instead. I left both Firewall and Defence+ set at Training Mode for the forst three days and everything was working fine. Yesterday, thinking that Comodo now knew what programs were running and having set my security programs to Trusted Applications, Firefox and IE as web browsers and System and Svchost to outgoing only in both Firewall and D+ I switched both the Firewall and Defence+ to Safe Mode. Last night I got the advertising pop up which comes with Avira update and exited it as I normally do but the update although it downloaded ok failed to install and I got an error message. I tried a few times last night and again this morning to update Avira manually but although it downloads it does not install. It was working ok while I had the Firewall and D+ in training mode so I think it may have something to do with Comodo. Can anyone tell me how to resolve this?. Like I say I have set all Avira entries to Trusted Applications in both the Network and Security Policies.

i can tell you about cis antivirus ;D first time you must waiting to update about 30,45 min.
i had same problem with Avira.Try to enable just firewall security

No miske84bg,
the 30% update stall I would get was after 5mins or so at 30% I could see the download stopping via the lights on my modem, next I would get a Comodo pop up telling me that the PC needed restarting for the updates to take effect. Sometimes on reboot I would still be on 1157, other times it would have partially updated to 1800 or so and then I would have one more update which would go all the way through to the latest and when I rebooted from that one it would then be up to date. What would happen then was that, a few days later I would install a program or something requiring a reboot and the AVDB would be back at 1157 when the whole calamity would start again. In the end I gave up and went back to Avira which I had used prior to CIS. I may try Comodo AV again in v4 if reports are good but for now I will stick with just the Firewall and D+ on proactive security.

when i updated first time antivirus,updating stop 30%,then waiting about 30 - 45 minutes