Comodo firewall + AMD ZeroCore [I49]

Hi,

Comodo firewall (Most up to date version and previous) have a big problem with the ZEROCORE system implemented on HD7000 or newer series from AMD.

Zerocore is a system that put the graphics card “sleeping” when the monitor is sleeping and if there isn’t any program that requires graphics card usage.

What is happening is, if close all the programs and only leave my antivirus, and comodo working in the background, when the screen turns off, the graphics card can’t “sleep”. You can see that because the graphic card fan never stops spinning.

If you disable comodo firewall, and exit is interface, then when the screen enter the “sleeping mode” the graphic card fans will stop spinning and the graphics card is “sleeping”.

If anyone here have an AMD HD7000 or the newer series, close your browser, skype, etc… And wait for the screen to be turned off by the windows… And then look at your graphics card fans :slight_smile:

Thanks.

Thank you for reporting this. However, please edit your first post such that it is in the main format provided here:
https://forums.comodo.com/bug-reports-cis/new-format-draft-do-not-use-yet-being-updated-t90436.0.html;msg651613#msg651613
Please copy and paste the code and put your responses after the colons. Also, remember to attach the required files.

The reason this is required is because the problem may be related to multiple components of your system. Thus, filling out that format ensures that the devs will have enough information to fully replicate the issue and ensure that it is not present in another way on a slightly different system.

Thank you and let me know if you have any questions or require any help.

Does turning off the animation of the system tray (aka Windows Notification Area, I think) work around this problem? What about disabling the widget?

Nop, I tested this.

I’m sorry but I don’t have time to put this bug into the formulary. Anyway, reproducing this is easy… Only needs an AMD HD7000 or the new serie.

  1. Set windows energy profile to put the screen sleeping after 1 minute of inactivity.
  2. Close all programs that use the graphics card.
  3. Look at the graphics card fan (we can use software to see this, but it’s inaccurate since that software can interfere with the results).

When I tested, I closed all the programs, and my tray icons are my antivirus, Comodo (with the animation disabled), catalyst (AMD Drivers), audio drivers, and nothing more.

When I have all of this tray icons except Comodo, and the screen enter the sleeping state, the graphics card fans stop spinning, and only starts when I press on a button or move the mouse to wake up the screen. When I have Comodo tray icon and the screen enter the sleeping start, the graphics card fans doesn’t stop, and keeps spinning… Comodo is making some request to the graphics card, I don’t know why.

Note: Every time I closed the comodo try icon, I disabled the firewall first (Since I only use the firewall, HIPS is disabled).

Thanks.

Just a reminder, please edit your first post using the format I linked to in my above post.

Thank you.

PM reminder sent.

For the time being I will move this to the Non-Format Verified board.

Topics in this board are rarely looked at by the devs, and even if they are it is unlikely the devs can fix the bugs reported. The reason is that putting bug reports in the required format, with the required files, ensures that the devs have enough information to understand and identify the bug. Thus, without this it becomes very difficult to replicate a bug such as yours.

To get your report forwarded to the devs please put this in the required format, and attach all required files.

If you have any questions please do not hesitate to ask.

Thank you.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are mainly not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments), so I can forward this to the devs and get this problem fixed.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (8.0.0.4337)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are mainly not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments), so I can forward this to the devs and get this problem fixed.

Thank you.