Comodo Firewall always stuck after a click mouse and eat CPU

Okay this is already get me a headache, Comodo Firewall is getting slow over time and now really slow to respond every choice I made in configuration menu. Just a simple case after I made a change in Advanced Settings and click OK or Apply (same with other settings menu), Comodo became not responding (but without became white window as not responding programs, it’s just not respond every click I made to any menu button) and eating up CPU load for 12,5%, seriously…? only 12,5%…? I have high-end CPU and Comodo only initialize for 12,5%…?

Every configuration I made, Every click I made to change any options in Advanced Settings, Comodo get stuck and eat up CPU for 12,5% and make waiting for up to 2-5 minutes. Seriously what is happened here…?

And for the latest, currently I’m testing a media server app named “Universal Media Server”, every time the app startup or make a restart for the server module, Comodo acting up again with eating up the CPU and make me wait for the media server working and detected in my TV. I totally can’t do anything with the media server app until Comodo finished eating up the CPU or I can say going idle state. Waiting and waiting for up to 5-10 minutes, come on…!!! Wasted an hour because of Comodo.

Guess what… Everything is smooth and normal without waiting after I DISABLED the Comodo Firewall, media server app working fine and detected in my TV. Everything is working without waiting another hour when Comodo Firewall is DISABLED. Seriously what is happened here…?

[attachment deleted by admin]

Please try to reinstall using this guide.

And again… is that the only solution for this…? I’ve already done THAT and ALL of THE STEPS even Cleaning Up totally what is left by Comodo Firewall… Reinstall and so on… After time… Comodo Firewall stucks again just what I told in the first post…

Do you have a lot of custom rules in the Firewall and D+ departments? That may explain it.

About 40+ application rules stored… Okay if that the caused of Comodo Firewall being stuck… Seriously…? Comodo couldn’t handle a lot custom rules…? I have hundreds of portable applications and other apps which is need an internet connection for an update… For Your Information 2 years ago Comodo Firewall version 3 can handle hundreds of Application Rules but now…? I didn’t use Defense+ or SandBox since last year and still the Firewall always stuck every click mouse made.

I have to disable the Comodo Firewall and make me think… Do I need uninstall Comodo Firewall for being slowing down because I’ve hundreds of apps…? Seriously…?

Or I need another Firewall app…? 5 years+ with Comodo Firewall came to this…?

Well… no. It was not clear.

  1. Does it crash in the end?
  2. Which process is the one that causes trouble?
  3. You should check logs for anything that might seem interesting.
  4. Please attach a diagnostics report.
  1. There is no crash whatsoever, it just stuck when Comodo Firewall still “thinking” or processing with THAT 12,5% of CPU, details already in the 1st post…!!!
  2. Which process…? Absolutely “cmdagent.exe”
  3. Seriously…?? I already check ALL of the LOGS or whatever is related to event viewer or something, ONLY Comodo Firewall is the CAUSE…!!
  4. Here you go… Diagonistic shows no error or anything… all normal…

[attachment deleted by admin]

Update to version <>.
Additionally, please use this guide.

If the issue persists then please create a bug report with the required format.

and why I didn’t receive any update when checking inside update menu…??? Clean reinstall all-over again…?? Great…

CIS v8 is not available on the program updater yet. Expect it in several weeks.

A very important step in the guide by Chrion linked by qmarius is to make sure there are no left over drivers from previously installed security programs. They can cause all sort of unwanted behaviours.

succesfully update without problem… the “stuck” still occured even not take a long time like before but still acceptable… I will report if there’s any problem…

You don’t have to endure any similar behavior. Please do create a bug report if you’re certain that FW is causing your issue.


Okay that’s it… this time Comodo Firewall going worst… again stuck in 12.5% of CPU usage for hours…!! Up to 2 minute of long delay to do anything… from open Task Manager even opening the Comodo Firewall any configuration window… What is really happening…? Is really Comodo Firewall couldn’t handle many custom rules…?

UPDATE: Okay this morning Comodo Firewall going worst again, bootup my notebook and guess what every programs that is runs on startup get stuck…!! Task Manager showing Comodo Firewall eat up 12.5% of CPU, again onlye 12.5%…!!! Seriously…?? Opening every programs, Firefox, CClenaer even Windows Explorer got delayed up to 5 minutes until shows up…


Do you have one or more programs installed that interfere with networking (have a driver installed for networking)? On another forum I saw a report where some type of utility of ASUS was creating performance issues with network connection.

I’m using Lenovo notebook with none of bloatwares or something useless… I’m just curious why after years of common usage, right now Comodo shows something that is really changed my mind to continue using it… Comodo is really slowing me down with that “only 12.5%” of CPU usage when any programs startup or need an internet connection, everything is got stuck up to 2 minutes or more (the worst is launching an Mailbird app and waiting for 5 minutes)…

Ow I forgot… It’s takes 10 seconds to waiting when opening the Comodo Firewall main UI from system tray… (yes 10 seconds), and 5 seconds to open any UI like Advanced Settings or else… (yes 5 seconds)

FYI, my spec is Core i7/8 GB RAM/SSD 60GB/1TB HDD… Tell me if the spec is not enough for that “12.5%”…!!

No solution…?

still no solution huh…? I’m going to uninstall Comodo Firewall tonight…

Today, while I want to install my new printer from EPSON, the driver installation progress got stuck for about 5 minutes caused by cmdagent.exe doing the 12.5% of CPU usage which is I didn’t know what it’s for…

7 years with Comodo Firewall come to the end… whatever…

Hey tridentcore,

We will try to find out the root cause of the problem.

Please let me know the details of your hardware( cpu type, capacity ) and also the details of the environment at the moment the problem occurs. Can you take screenshot of the running processes ?

Waiting for your reply,

Kind Regards

I’ve already explained everything even the details about my problem in the first post but still no comodo staff ever contacted me about it for examining the problem, dunno why but maybe I’m not a paid user so this is not a priority support or whatever. Maybe this is the last time I will explain to you about my problem before uninstall the app.

SPEC : Intel Core i7 + 8GB DDR3 RAM + 60GB SSD + 1TB HDD (Lenovo IdeaPad Y550P notebook)

OS : Windows 7 Home Premium 64bit + Norton Antivirus + MalwareBytes Anti-Malware

My notebook connected with 3 of 3TB WD Essential external hard drives, 1 EPSON All-in-One Printer, 2 USB Optical Drive (ASUS dan LG).

I have 130 of running processes and that is the condition for the last 6 months and the problem occured with Comodo Firewall about November without any technical reason whatsoever. Already upgraded to the latest version but still not a solution. Task Manager screenshots attached.

I’m going to uninstall Comodo Firewall tonight, because the problem is going worst even in a normal situation and I’m not comfortable with it.

Will back to Comodo Firewall if there’s fix and explanation about my problem.


[attachment deleted by admin]