COMODO Firewall Alert freezes causing full PC hang [M395] [v6]

A. The bug/issue

  1. What you did: Ran file ‘Neverwinter_NW.1.20130416a.6.exe’ (D/L Link: http://download.perfectworld.com/nw/Neverwinter_NW.1.20130416a.6.exe) or some other random files including Explorer.exe too
  2. What actually happened or you actually saw: COMODO Firewall Alert freezes upon making a decision (in my case, I clicked Allow). Later the whole PC starts to freeze as well.
  3. What you expected to happen or see: COMODO Firewall Alert to create an Allowing Rule and then disappear.
  4. How you tried to fix it & what happened: No fix have been found yet, only way to get out of the hung PC situation is to do a hard-restart.
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?: No
  6. Details & exact version of any software (except CIS) involved (with download link unless malware): None
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Yes, I can make the problem happen again by simply running the ‘Neverwinter_NW.1.20130416a.6.exe’ file again.
  8. Any other information (eg your guess regarding the cause, with reasons): No idea at all why this is happening.

B. Your set-up

  1. CIS version, AV database version & configuration used: CIS v6.1.276867.2813, AV DB v16230 & Proactive Security
  2. a) Have you updated (without uninstall) from from a previous version of CIS: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Yes, made changes to default config.
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: D+/HIPS= Safe Mode , ASB/BB= Partially Limited , Firewall = Safe Mode , AV = Recommended Settings
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 8 Pro x64 (Media Center Edition), UAC Disabled & Account type: Admin
  7. Other security and utility software currently installed: None
  8. Other security software previously installed at any time since Windows was last installed: None
  9. Virtual machine used (Please do NOT use Virtual box): No

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post:

  • Your ‘Watch Activity Process’ list

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again

Mouse

As per your request, I have attached the ‘Watch Activity Process’ list. Please see the below attachment.
If you need anything else, then kindly let me know.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

For those experiencing this issue. I have the following work-around.
Download process hacker here: http://processhacker.sourceforge.net/

Make sure you start it as soon as you have a desktop, and select ‘Hacker’ show all processes, so it alerts UAC for admin account.
Now if you alert freezes, switch to Process Hacker and select CisTray.exe, now right click and press Terminate tree.
After that you select cmdagent.exe and use the ‘restart’ option.

That should give you your system back.

If you are running ProActive Security you have to go to HIPS rules find the Comodo group, go to protections and add ProcessHacker to the exceptions for memory access and terminate.

I have same problem. Random programs randomly can freeze hole PC when Firewall Alert

B. Your set-up

  1. CIS version, AV database version & configuration used: CIS v6.1.276867.2813, AV DB v16230 & Proactive Security
  2. a) Have you updated (without uninstall) from from a previous version of CIS: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Yes, made changes to default config.
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: D+/HIPS= Safe Mode , ASB/BB= Untrusted , Firewall = Safe Mode , AV = Recommended Settings
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 x64 Service Pack 1 UAC ON account type ADmin
  7. Other security and utility software currently installed: None
  8. Other security software previously installed at any time since Windows was last installed: None
  9. Virtual machine used (Please do NOT use Virtual box): No

Thanks for the replication information

I think I have fixed my problem, I don’t know since when Windows Service - ‘Application Experience’ was disabled. I didn’t do it so I had no idea about this until today. I enabled to it’s default state (i.e Application Experience set as Manual (Trigger Start) ). Later I tried to reproduce the bug, but it didn’t occur.

I had to make sure about this so I disabled it again for testing and ran the mentioned file. Result was that the bug occurred again.

I’m not sure about other users until the try it out.

That’s interesting. Please keep us informed.

Update:

The Bug has evolved further, this time Firewall Alert doesn’t freeze but PC still gets stuck. Temporary fix mentioned by Ronny works and PC gets stable. It is still a matter of luck, if I am not able to open Process Hacker then I need to do a hard-restart…

This Bug feels like COMODO is denying my all permissions to the PC, things doesn’t start at all as they time-out and as soon as close CIS, everything is back to normal.

Am having this same bug.

I couldn’t restart the CMDagent.exe after terminating the CIStray.exe/cis.exe, so i had to double click the COMODO Internet Security icon and it started back up and worked.

I have same problem. After system start up first Comodo alert causes freeze and I must restart :frowning:

  1. CIS version, AV database version & configuration used: CIS v5.12.59641.2599.
  2. a) Have you updated (without uninstall) from from a previous version of CIS: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: Yes
    b) if so, have U tried a standard config (without losing settings - if not please do)?: I don’t know how to do it, when Comodo freeze PC. Actaully I disabled Comodo Internet Security Helper Service and Comodo Internet Security in msconfig.
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No. As above :frowning:
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: D+/HIPS= Paranoic , ASB/BB= Untrusted , Firewall = Safe Mode
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 x64 Service Pack 1 UAC on, account type Admin
  7. Other security and utility software currently installed: Avira Free
  8. Other security software previously installed at any time since Windows was last installed: None
  9. Virtual machine used (Please do NOT use Virtual box): No

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Ok, I will recheck if the bug is fixed in this latest v6.2.282872.2847 or not.

Thank you. Please let me know what you find.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Hi Chiron,

I haven’t encountered this bug since 2 months+ so I think it has been fixed, but if I get this issue again in the future then I will report back here.

Thanks to COMODO Support Team.

Regards

Thank you for checking this. In that case I will move this to Resolved.

Let me know if the issue returns.

Thanks.

Im sad to say it’s happening to me on the latest version of Comodo Internet Security Pro Version 6.3.302093.2976

Can you please explain in detail exactly what causes the PC to hang? Is it exactly the same problem as xXShutterXx described or are there small differences?

Also, please reinstall by following the advice I give in this topic and let me know if it solves your problem. This may be solvable without having to wait for a bug fix.

Keep me updated.

Thank you.