Comodo Firewall 7 error after installing Faronics Deep Freeze 8.1 [M1213]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Yes easily reproduce the problem on a year old Windows install and tested on clean Windows install with only board drivers installed.

If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1:Make a fresh install of Windows and then immediately install Comodo Firewall 7.0.55655.4142.
2:Then install the latest Faronics Deep Freeze 8.1 standard (or in trial). The problem starts after installing Deepfreeze.
3:On every boot there is a pop up which says “COMODO Security Agent could not be started.” Uninstalling Faronics does not make this error message go away. Also even after uninstalling Comodo, running the removal tool, and reinstalling I still get the same error message.

One or two sentences explaining what actually happened:
Error pop up on every Windows startup “COMODO Security Agent could not be started. Would you like to run the diagnostics tool to fix this error?”. Clicking on “No” and trying to start Comodo firewall I get the same error. If I click on Yes then Diagnostics completes without finding any errors. Can run Comodo now but it doesn’t remember settings changes on next reboot along with error on startups.

One or two sentences explaining what you expected to happen:
No errors.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
Yes.

Any software except CIS/OS involved? If so - name, & exact version:
None except security programs described below.

Any other information, eg your guess at the cause, how U tried to fix it etc:
Tried Chiron uninstall guides guides and it did not help:
https://forums.comodo.com/install-setup-configuration-help-cis/most-effective-way-to-reinstallupdate-cis-to-avoidfix-problems-t58620.0.html
Comodo Firewall 6.3 works well alongside Deep Freeze.

B. YOUR SETUP
Exact CIS version & configuration:
Comodo Firewall 7.0.55655.4142 with Proactive configuration

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
D+/HIPS and Firewall.

Have U made any other changes to the default config? (egs here.):
D+/HIPS “Create rules for safe applications”.
Firewall “Create rules for safe applications” and ticked in all the “Advanced” settings.

Have U updated (without uninstall) from CIS 5 or CIS6?:
Yes from CFW 6.3.
if so, have U tried a a a clean reinstall - if not please do?:
Yes tried clean reinstall using Chiron uninstall guides. Also on clean Windows install with no previous Comodo, install from 6.3 or latest version 7 (restored backup each try).

Have U imported a config from a previous version of CIS:
No.
if so, have U tried a standard config - if not please do:
Yes tried.

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7, SP1, 64 bit, UAC on default setting, admin, only on real machine no V.Machine used.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Sandboxie, free on demand scanner Malwarebytes Anti-Malware 2.0.2. (on clean Windows test install didn’t install those, just board drivers) b=none.

[attachment deleted by admin]

Please try reinstalling CIS by following the advice provided in this post and let me know if that solves this. Often a normal reinstall does not fix errors of this type, but a reinstall by following those methods does.

Let me know what you find.

Thanks.

FIXED thank you Chiron! :smiley: <3

Only had to run through “Section A” and used the CIS Premium installer from your guide, instead of the Firewall standalone installer I had as backup.

Also fyi I didn’t uninstall Deep Freeze but had to uninstall/install after following your guide. Maybe it would’ve been best to uninstall both one after the other, then follow your guide.

It’s possible that installing Deepfreeze after CIS also helped in some way. I’m not sure why it would matter in this situation, but perhaps it did.

Regardless, I’m happy to hear that the problem is solved. In that case I will move this bug report to Resolved. If you run into any other problems, or this problem returns, please be sure to let me know.

Thank you.

Went to further test on a clean Windows install with only board drivers and made a backup. Because to install new or older Deep Freeze versions you’re forced to uninstall current install and thought I would have to go through this again or maybe it’s just something wrong with Windows settings or something.

Installed Comodo 7 and then Deep Freeze 8.1. Same error and Comodo not starting.

This time uninstalled both, ran your guide, Comodo install, Deep Freeze install and get same error. Uninstalled both again, your guide, install Comodo only…error. Ran you guide multiple times with same error.

Restored backup. Installed the older Comodo 6.3 and Deep Freeze with no problems. Upgraded Comodo to version 7 with backup installer, same error.

Will this be fixed in next Comodo release? Since 6.3 and previous versions worked great with Deep Freeze. If not then I’m stuck using the out dated Comodo 6.3 or trying a different firewall which I’m reluctant to do and posting here.

As this problem is not going away, I will move this report back to the main bug reporting board for processing.

Please edit your first post so that it is in the format provided here. If you have any questions about how to do this please feel free to ask. This format will give me deeper insight into the problem. Without it I cannot forward this to the devs.

Thank you.

Updated!
Thanks

What do you mean when you say that “boots frozen until you boot thaw in options”? Does this happen each time? Also, I’m not sure what you are referring to when you say “boot thaw in options”. What did you do in order to get it to boot without freezing?

Thanks.

Edited that out, normal Deepfreeze setting after installing (enabled). Enabled (Boot Frozen) or disable (Boot Thaw).

Thank you. I made some more changes to the section about reproducing this. Is everything I put down correct?

Sorry for the confusion I was in a hurry to edit in bug report format. i think it’s ok to leave them out but my reply to your additions

  1. Doesn’t matter the setting you set in deepfreeze, just installing it deepfreeze will start the Comodo error on startups. To change deepfreeze settings (frozen/thaw) hold shift double click on the icon in notification area or ctrl+alt+shift+f6.

  2. Uninstalling deepfreeze will not fix the Comodo error on startups or uninstalling Comodo and using your guide will not fix the error on startups.

Okay, is what it currently reads correct as to the conflict with Deepfreeze (note, I made a few modifications)?

Also, are you saying that regardless of whether Deepfreeze was ever installed (even with a fresh OS) you receive these error messages from CIS? If so, is there any way in which you have found to make these error messages go away?

Thanks.

Fresh OS, board drivers install, Comodo 7 install and everything is fine until I install Deep Freeze. Error messages only after installing Deepfreeze. Uninstalling deepfreeze will not fix the Comodo error on startups or uninstalling Comodo and using your guide will not fix the error on startups with another Comodo install.

Do you mean that even if you uninstall Deepfreeze, then uninstall and reinstall CIS by following my advice, that is still not able to fix this CIS error message after reinstallation?

On the older OS install worked as posted previously. On the fresh OS install your guide did not work. I just tried on the fresh OS backup to test again and have same results. Also tested in vmware with same error message.

Another test this time on a laptop, Windows 7, SP1, 32bit. Comodo firewall 7 and Deepfreeze 8, same error message.

I just updated your first post. Does it now correctly describe what you are experiencing with respect to both the freezes and the Comodo Firewall error messages?

Thanks.

:smiley: Yes except I edited out 4. and about freezes (I don’t mean the computer locking up like it hung/bsod/etc)… please ignore everything I wrote about how Deepfreeze functions (auto-start freeze/thaw), Deepfreeze works as intended with Comodo installed or not. Thanks Chiron!

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Another of the Mods believes this could possibly be caused by a hooking conflict. Please try excluding from both the Auto-Sandbox and the shellcode and reboot. In addition does making it, and all related files, trusted help?

If that does not work please try switching off or on advanced protection mode and reboot.

Let me know if either of these approaches helps.

Thanks.