Comodo Firewall has been released!

Yes I have. ;D


I’ve tried three times and the same error appear.
The only way I’ve managed this was uninstalling, booting, installing again…
But then, Windows Security Center did not recognize the new Comodo version.
I had no trouble with the old and the beta ones ::slight_smile:

I made a clean install, i.e. clean the disk and registry after uninstall the previous version…

Until now everything seems to work well, except this bug:

  • When click on the “<< Previous” or “Next >>” and when their aren’t any new Adapter to see, but if I click again where the “<< Previous” or “Next >>” was before, I received attached error.

[attachment deleted by admin]

The new version keeps closing down for no apparent reason… :frowning:

Hi All

Some advice for a newbie please - I am presently running version do I have to uninstall it before downloading the latest version. There have been a lot of updates arriving tonight and I was wondering if that was the new version arriving. I have not yet restarted my computer to see if there are any changes to version numbers etc. Or do I have to go to the home pages to download from there.

Thank you in advance

For me the same… Windows Security Center does not detect it…
Does anybody know what is happening?
The last version never gave me these troubles…

I have tried to get the new version of CPF with no success whatever! I did get a new license code by e-mail, although I already have an older one and should not need a new one. However, I end up in an endless loop of being asked for name, etc., and getting no download to dtart! Was macht?

Indeed, the updates were not being finished…
You need to download the new setup.exe file, uninstall the old version, boot, install the new one, boot :wink:

On the “Order Confirmation” page, just below the “Total Value” there’s a small link stated; “Click here…”. Click on that link, and you’ll get the installation file.

*. I think, the link should be more visualising rather than just “Click here…”

Hi, I was just wondering if you need to receive a new activation key inorder to use the new version. I already have an activation key from version If not, what is the process inorder to download the new version setup.exe, as I am also having trouble getting it through the updater with the Error 108? Any help would be appreciated thanks (:WIN)

Please refer to the folowing link:,2019.0.html

Yes I noticed the same here. But the firewall continues working, even if the last shown adapter is not connected.
XP Home SP2

Hmm… another cosmetics error…

The same problem here, you can click on previous or next when it is not visible, after that an error occurs.

Mine wouldn’t update either. I just uninstalled and installed the new one. No real probs.

Have to say what a difference the new version has made. Absolutely magic. The previous version was a tad slow when clicking permit or deny, this version flys.
Fantastic work from everyone at Comodo and a big thumbs up to all the beta testers. This is one of the best bits of software anywhere.

Keep up the great work.

(I’ll be telling everyone I know about this software) (:CLP)


I am a fan of COMODO Personal Firewall. However, I am truly disappointed in the untimely release of It is not difficult to test the updater function on a few client computers to determine if it will complete successfully.

This A.M., I had a notice that updates were available for CPF, did I wish to install? Certainly, say I. However, the update never completed (with no failure message of any kind). So, I manually invoke the updater, only to find that the program download and install is failing at 82% with an error message oft reported in this forum.

Undaunted, I d/l a clean version of from the web site, export HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall, as recommended in this thread, uninstall my current version of CPF, install, shut it down, import HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall and reboot. Shortly after reboot CPF shuts down and reloads the windows firewall with a critical error which indicates it no longer likes the registry detail, even though a check of CPF indicates the registry data is accepted and displayed in both component and app windows.

I love CPF and and am anxious to take advantage of the improvements in However, I have reloaded my clean copy of and will reamain at this level until you fix the automatic updater issue which prevents a successful install. I am not interested in going through the process of reinstalling all apps and components again…

On edit: Version also seems to be blocking another application I use (Registry Healer) from doing it’s job. Works fine with version, blocks writes to the registry in This could be a result of the registry keys protection employed in however, I can’t be sure until I am able to install a workign version of without having to endure what another poster in the forum called “popup hell”…

I hope you can get the auto updater function fixed soon…

I’ve just uninstalled and installed new v2.3 . Everything gone fine and new version of Personal Firewall is running in background. I’ve also restored previous rules using a .reg file exported before uninstall the old version.
Now I would like to know how to get rid off Comodo Launch Pad; I’m unsure if it’s necessary or I can remove it safely, without affecting the work con the personal firewall.

Please let me know (V)

To Melih and the Crew
What can i say except “Just brilliant!!” Works perfect and still waiting for Cavs so i have a complete suite.
Great job guys keep it up.

I tried to down load this update but it failed to update on prev version . I have tried uninstalling prev version and downloading / installing this new version but seems to say it is the old version which is . It their any particular reason for this then is seems to ask me to update it , but then does’nt seem to update which is starting to get a little annoying now ? As I would very much like to install this new version and take advantage of it’s improvements . Many Thanks

Don’t think you can remove the launchpad, but you can hide the launchpad icon, just rightclick on it and choose options.