COMODO "Engine initialization failure"

Today, i turned on the pc and Comodo has stopped working -viz (Zdjęcie - 08.04.2015 |, i tried to restart the pc - the same, i re-install Comodo - the same, but it did not appear that white window … only gadgets - notice: requires attention … but nothing works.
I do not know what to do next :frowning:

My pc : Amd FX 6350, 8Gb Ram, 2 TB HDD, AMD 7850 Radeon.

thank you in advance, I am sorry for my bad English.
Czech Republic

Please try reinstalling CIS following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable clean starting point.

Thx EricJH, i did everything according to instructions - uninstall Comodo “add/remove programs”, restart PC, and launch Safe Mode Win7 (64bit SP1) … i started here program Uninstaller Tool v0.3b as administrator, i gave option" 1 Comodo Internet Security " -opened the cmd window and here confirmed the choice of 1 … something done, wiped , next restart PC … instal new CIS version aaand again the same thing :-(.
moreover, even to destroy Windows, no sound, it finds HW, and other problems with HW … I used the emergency mode, now it does not work too well.
I’ll have to reinstall windows :-/ unfortunately.

Even so much for your help … sorry for my bad English :-/

I have the exact same problem, it has begun after latest updates. (I am using win7 x64)

I have tried the guide and it wasn`t helpful. The only thing that is working is installing older version of firewall (fw_installer_5732_83.exe)

Installing or updating to the new version result in those white windows with “engine initialization failure”

I am really tired of re-installing comodo and I can`t find any solution on forum, also nothing changed with even lastest updates. Also I fully re-installed windows 7 since then and nothing changed: older version works perfectly, newer is broken.

I have exact the same problem as well. Uninstalled Comodo, following the provided method as suggested above. This lead me to a BSOD at windows startup, so I had to reinstall windows 7 64bit.

Installed CIS with an old version which worked fine until it updated to the last version.

I have again the same problem.

Clean version of windows 7 x64 Comodo is one of the few running programs.

I hope there will be some more advice, instead of just uninstall and reinstall. Been there, done that, including a full windows reinstall.

Hi Guys,

Did anyone here find a fix?!

I just bought a new CPU and Motherboard and installed them last night.
I installed Windows 7 on a fresh HDD and Comodo was the first App to be downloaded and installed on my PC.

After installing it it did not work. “ENGINE INITIALIZATION FAILURE”. I uninstalled it and re installed it about 5 times trying updating windows first but no success.

COMODO said either I had a registry problem or a virus.

To be absolutely sure that both of these were not the case: I re-installed windows a second time.

Second time:
I re-started my pc after each driver was installed and CIS was the first program to be downloaded and installed.


Has anyone got a solution?

This would be greatly appreciated.
The COMODO help team from Geek Buddy told me I have ‘errors in my system’ but windows has just been installed and I feel this is not the case and that they are after a subscription.

Any help would be greatly appreciated.

Thanks in advance,


[attachment deleted by admin]


Installed Windows 7 Service Pack 1 (apparently I did it in a few parts and now it popped up as if it were always working).

I hope this solves some peoples frustration!!

Thanks Guys.

…flies away

Hi Tom.
What did you do? To get it work?