Comodo driver blocks incoming ports on Windows 7 64-bit

To make this short, I noticed all my incoming ports were blocked even though I allowed specific programs access to ports.
Finally decided to try Safe Mode with Network, which resulted in the ports being opened.
I then uninstalled Comodo and saw my ports were open again.
Disabling Comodo service and startup did not help, so the problem must be the driver. What should I do, if I don’t want to switch to another firewall?

Depending on the options you chose during installation, inbound connections are blocked by default. If you open:

CIS/Firewall/Network Security Policy/Global rules

Is the final rule:

Block IP In Any Any (see image)

[attachment deleted by admin]

Thanks, man! That did the trick.