Comodo drastically lowers network performance


Here is my problem description:

Lately (last two weeks) I’ve noticed that network performance on my system has been progressivly slower and slower. With my curiosity peaked, I decided to investigate the problem by running a speed test. I was surprised to see that my performance now is ~ 6/1 Mbit as opposed to normal which is 50/10 Mbit. I’ve checked this performance with multiple testing tools which verify the results.

Confirmed information:

  • I’m running Windows Vista Ultimate x64

  • Hardware is ruled out as other machines have full network performance (and are not running comodo)

  • Configuration issue is ruled out also as reinstalling comodo 4 with default settings does not resolve the issue

  • Disabling comodo does not resolve the issue either

  • Completely uninstalling Comodo returns network performance to normal

  • Logs are empty while this is happening as well

  • Zonealarm successfully blocks traffic while not having this issue (both firewalls were not installed at the same time)

Additional notes:

Since I upgraded from Comodo 3 to 4, I’ve also noticed that it tends to crash at least three to four times a week. Restarting the firewall after that resolves the issue as it only happens once upon boot.

Really, if anyone knows where I can download the last version of Comodo 3 again, please let me know as I’d rather not spend more time messing about with this inferior version if I can avoid it. Also, going back to zonealarm temporarily has also reminded me how incredibly great comodo is (excluding version 4 naturally)

Edit: I’ve found the last version of edition 3 which I’ve now installed, everything is back to normal again and no crashes yet, and if my hunch is correct, I won’t have any either. Unless somebody can help me resolve this odd problem, I think I’ll wait until there is a major code update before trying comodo again.

Are there any other security or network related programs running at the same time?

Would you be so kind as to say where you found the newest version of firewall 3.14?

Only other thing that’s running is avast! antivirus (5.0.545) as I keep such devices to a minimum.

@ Proteus, I did a search on these forums actually and they linked to:

Thank you, but Comodo lists my firewall version as 3.5.54375.427 and my Internet Security as 3.14.147648.588, and Filehippo does not seem to offer those.

Version 3.14.147648.588 is the latest version released for the v3 branch. Notice that v3.5 was before 3.14 (the version numbers of the v3 series were a bit convoluted).

I agree - there is a drastic slow down after upgrading to the new package. I’m currently in the process of reverting to an older version

Yes me too. My system is Windows 7 Ultimate 64 Bits. The network slow down considerable. Please correct this Comodo. My lastest version is: 4.1.150349.920

Now it’s been a few days and it seems as though nobody can wager why this newest version is behaving this way. However, I haven’t had any issues whatsoever since I rolled back to the previous version (3.14) so it would imply that the newer version has some severe issues on x64 systems.

As it seems that no action is being taken, I would suggest that everybody whose reading this and has this exact problem (crashing firewall/slow network performance) register on the forums and post their symptoms and specs in this thread. Then maybe something will happen in regards to finding out what the issue is. Now it seems that as the topic is forgotten , the issue apparently is too.

FWIW, I’m also running latest Comodo FW and Avast5 Free Antivirus on a Win7 x64 system and having no such problems here. My only other reatlime security is SuperAntispyware Pro. PC is not crashing and performance did not take a hit when any of them were installed. May be something specific to your configuration. I’m sure someone will have some further thoughts and things you might pursue to find the cause of your problem. Wonder if you could have gotten a corrupted download. That has happened to me before. Have you tried downloading a fresh copy of Comodo, doing the total uninstall and then a clean install using the new copy?

Yeah, that’s standard procedure for me having been an ADSL user for many years before :wink:
I so don’t miss that ISP hahahah, but I digress, the system with the old firewall has remained stable and the new version fails to work for some reason. I’ve even tried checking the event viewer logs for anything out of the ordinary, but they come up with absolutely zip in regards to errors with the F/W as well.

At this point, I feel I’ve exhausted all ideas I have as well, so anything else is highly welcome.