Comodo Dragon Version is now available.

Sorry about that.
been fighting with pop ups and other things that I was just trying to get everything out quickly as FF is a joke and the only thing allowing me to work relatively safely is the Comodo internet protection.

Hi ValorJ,
No apology required. :slight_smile:
The Forum is a big place and very easy to miss things.

Kind regards.

:slight_smile: Its not obvious … but you have dumped what you may have wanted to keep
AdSanitizer, supported by AdTrustMedia, replacing malicious Ads = PrivDog with a new name

I also disabled AdSanitizer simply because ads started appearing on several of my favorite websites where they hadn’t before. I don’t use any special ad-blocking software, either.

Oh, so it actually introduces ads where before there were none ?, bizarre. Its supposed to just replace ads with ones provided by adtrustmedia ( another of Melihs ventures which was setup to support this plugin ), unless the ads come from advertisers registered with adtrustmedia and prove clean then the originals would show. It also blocks malicious ads and other tricks … But I think adding ads where there are none ordinarily is a new trick the old dog has learned.

You might want to report that as a possible bug in the adsanitizer part of the forum ( if there is one, I have not looked )

Edit : Maybe report it somewhere here

I cant even get this version of Comodo Dragon installed, it goes through the motions ,the installer crashes, cd fails to start, couldnt even uninstall it, and I had to manually delete the folders and reinstall v36.1

I thought I was the only one that lost all my plugins… looks like you did to. I’m just trying to get flash and all my previous plugins back into the new version of dragon…

I loved comodo to play my favorite game on Facebook , but now i got the message it doesn’t support unity webplayer. Comodo was the best browser for it. What can i do??

Hi, antivirus Avast stop the download.
It report:


Infection: Win32:Evo-gen [Susp]


Also [at] jdh - Some of the following probably applies to your experience reference NPAPI and things not working in chrome code

[at] Crossclown - No I un-install all the extras CD comes with, imho they are just more things to go wrong, or potentially be exploited, and most of them do not contribute to the Privacy and Security of the browser

I think the installer does try to respect your previous preferences, so if at one time you un-installed an old plugin that CD came with, the installer will not install it again ( I think anyway ) …

… However they are on your hard drive

So if you open a windows explorer window ( My Computer or My Documents ), and navigate to :

C:\ Program files \ Comodo \ Dragon \ Extensions \

In there you will see a bunch of .crx files

Now keep that window open but bring Dragon to the front

Go to Dragons menu, More Tools, and choose Extensions

Now bring the window with .crxs to the front again, and resize the window so that you can drag and drop those files onto Dragons Extensions window …

Whatever you drag and drop will then install ( or they should do :slight_smile: )

Though Dragon is now catching up with the latest Chrome code, so any old NPAPI extras will not work. Like Adobes Flash.
See this blog Chromium Blog: The Final Countdown for NPAPI

But if they are PPAPI they will work ( like Pepperflash which google makes for their own Chrome browser )
Any extensions on Googles extension site which used to be NPAPI will be getting weeded out of there ( if they havent been already ). Its to try and stop people potentially installing malware disguised as extensions, but also Adobes own brand of flash breaks the privilege levels in chrome, so is also undesireable because potentially it could be exploited if adobe lose the plot occasionally ( and historically they often do ).

So if you want flash in Dragon going forward, you will also need to install Googles chrome and get pepperflash out of its installation … Or, ya know if you want to have a browser with plugins which degrades the privacy and security of the browser - Just use Google Chrome for watching YouTube, and keep Dragon for general browsing on potentially dodgy sites without any extensions or plugins to degrade it.

Hope some of that helps as a workaround, but might be a good idea to give a bug report with as much detail as possible as to how your installation ended up the way it did - See “How to submit bug reports” here

I think thats Avast giving false positives again

Check the file out with VirusTotal

Here’s my results VirusTotal

A couple timed out, but thats a pretty overwhelming clean bill for all the ones that did not time out, including Avasts online scan proving it clean

I don’t think it is a bug. IIRC, I disabled PrivDog in all of the previous versions of CD for the same reason.

edit: nevermind, I fixed the problem.

Yesterday I was write it to a wrong topic so I take up the question again in the right place.

I always get this error. Adobe plug in not up to date disable it, but I updated it, and comodo always get crashed.
After the flash update everything works perfectly but after a browser restart the flash control writeing pepperflash and a non exist directory is writen. c:\pepperflash\

Hi Wezli,
Can you please check your Flash version at one of the following sites?


Dare I ask about x64 Dragon?

Is it coming out?

That would be cool :slight_smile:

I dont understand every time after update flash my version is 18… but after a browser restert everything vent back to Your Flash Version

Looks like problem solved I forget the command line arg-s what I changed fro 33. for fix the flash player problem

New problem. Ad Sanitizer not loading in because chrome-extension://mbklemiimcpdblemkogjenikmcfhpnib/html/panel.html not found. How can I fix it? Or how can I redownload ad sanitizer? Tried to repair option in install but not solved the problem