Comodo Dragon ver 24.1 is now available for download

Yes, it was the first thing I checked after the first failed install, and was always running during the next failures.

And the portable version also gives me that yellow bar new version available download

Can uninstall of dragon & selecting remove user profile can mess with C:\Users\Users Name Account?

if you select “remove user profile”, when you redownload & reinstall dragon, it should be like first time when it’s done

BTW - when I did the last DL & reinstall I used Int Exp & it went smooth

Oh, I know what you mean - remove user profile only applies to dragon - it wont change any machine settings

I asked this coz on my system C:\Users\Account Name has become not accessible.

Hi Naren,
The issues that you are having appear to be very system specific, I am sorry I cannot reproduce either with the installed or portable versions.

This might be worth considering a Bug report, if you decide to go ahead please follow the Bug report guidelines in the hope that the Developers can reproduce the issue.

Now I am trying version 13.4 the oldest version I could find on filehippo. If it works fine then I will try to update it manually with the version 24.1.

It didn’t worked, same prob.


Please attach all “dragon_updater” files from the following location: %windir%\Temp\ComodoLogsFolder. This will help us investigate the issue.

Thank you.


[attachment deleted by admin]

Are you using the portable or non-portable version?
If you are using the non-portable version please attach the “dragon_updater” files from this location: %windir%\Temp\ComodoLogsFolder.

Thank you.


Please add a detailed bug report so we can investigate the issue.

Thank you.

Here is the bug report

Automatic Update failed, Settings were not saved & reverted back when CD was restarted. Tried reinstall with no success.

Maually updated but settings reverting back prob was still there.

CD version 23.4, 24, 24.1, 23, 22.1, 22, 13.4 all stable versions, tried all these versions, some solved autoupdate prob but settings reverting back prob was there with every version whether automatically updated, manually updated or fresh installed.

Only CD default plugins were there & that too disabled, no other plugins.

Win 7 64 Bits

UAC Disabled

Installed on default C Drive

Program Files (86)

Administrator Account

I’m using a non-portable version of CD.
Log is attached.

[attachment deleted by admin]

I personally have no idea what is going on Naren, but this has to be a system related issue.
Ideas anyone?

…the only thing I can think of “maybe” (& it’s a BIG maybe) is, since I’ve seen issues recently with the comodo dns (ie. malware domain filtering), blocking things, (I “had” an issue as well), did naren do the “switch now” thing & set comodo dns at system wide & “maybe” discombobulating things? “maybe”?..IDK?..

Hi ultradolby1,
Thanks for the idea, one other thing I thought of is if he is signed into sync maybe. :-
Any ideas are good, I have nearly run out. :smiley:

I was not singed into sync, I had no options selected in the advanced setting (DNS, Malware, ect…). Only extension was Adblock (not plus). COMODO update service set to manual for the fist try, and manual running for the next 3. Only realtime protection is EXE Radar Pro and it was disabled all 4 times.