Comodo Dragon ver 20.1 is now available for download

Comodo Dragon 20.1 is now available for download from the following link:
http://download.comodo.com/dragon/DragonSetup.exe

IMPROVED:

  • Dragon is based on Chromium 20.0.1132.57.

FIXED:

  • Fixed tabs layout.

Thanks for the update, installed smoothly. :-TU

I think there is some error in update notification.

[attachment deleted by admin]

Casachit …
Yeah saw that also >:(
Don’t want anything Google on my machines, Thanks >:(

Nice smooth job apart from that! :-TU

An eye for detail,
Good pick up guys I missed that on my first system, but noticed it on the second. :slight_smile:

Again my CD did not update automatically and hung when trying to update it through the browser “about” function. I have to update it manually using the link on the Comodo site.

Google
:smiley: :smiley: :smiley:

Good job, guys :-TU
Since CD 20 you have fixed the creation of the link on the desktop every time CD updates, no matter if the link was already there or not.
Now you should fix the creation of an entry in the Start Menu.
For example, I don’t have it (I just have an icon in the quick start), but CD creates this entry every time it updates… it’s not a big issue, but it’s annoying and i think easy to fix :smiley:

Since CD gives that Google Chrome update message, i have to ask…is it still the latest update for Comodo Dragon that gets downloaded and installed?

Yes.

Okay, thanks Siketa. :slight_smile:

Same problem here since version 17. The direct download to the installer and then running the downloaded installer has worked well everytime.

What is this about “FIXED TABS LAYOUT”? The tabs on my copies of C D have been fine. I never see/found any problem with tabs. (Still on version 20.0.1)

Just now downloaded the new installer. The Download’s message on the bottom of Comodo Dragon says, “Insufficient Permissions”. Does this mean I need to download the installer again? Is it an unimportant message? 28.1MB.

[…] I tried a second download. This time there is no size designation in the finished download indicator and there neither is any message such as any “Insufficient Permissions”. My thoughts are something is faulty about downloading. Yes still using version 20.0.1

Hi string_game,

It is a bug since version 20.0 on some Win XP SP3 machines. See here https://forums.comodo.com/bug-reports-cd/problem-with-downloads-t85327.0.html

Interesting. That is in fact the operating system I am using. Now that I downloaded the version 20.1 CD twice, could they be considered both the same?

Noticed today when I ran the File Hippo UPdate Checker that there was a new version of Comodo Dragon available!

To reduce ram usage a few days ago I had gone into services.msc and changed both Dragons from Auto and Start to just Manual.

This would not allow me to do any update directly through Dragon. Changed it back to Start and the update automatically downloaded.

First update image shows the error message and the 2nd image shows the update.

Something else that I had not noticed before is that the Site Inspector that used to be beside the AdBlock icon was missing when I go to Extensions it is Enabled and you can see it above.
Site Inspector does show correctly in IceDragon

Edit: Possible cause is the url window has increased blocking out extra icons to its right. Last image

Thanks UncleDoug

[attachment deleted by admin]

Hi UncleDoug,
The first image could be due to a temporary, minor glitch in connection.

Even with the service disabled, you should still get the notification about an update upon starting Dragon with the option to download/install.

The site inspector button is missing in the 4th image because you are in incognito (In that image) and extensions are disabled in incognito by default.
Go to extensions and tick allow in incognito for site inspector or any other extensions you would like to allow.

Hi again Captian,

  1. The first image could be due to a temporary, minor glitch in connection.

It could be, but I tried 5-7 times over a 30 minute period and did not begin downloading the update until I changed it to start in services.msc. Could be coincidence ?

  1. Thank you that did the trick
The site inspector button is missing in the 4th image because you are in incognito (In that image) and extensions are disabled in incognito by default

What through me off was that the AdBlock icon was there. I don’t remember clicking run in incognito mode but there is the check mark in the image of the plugins I have installed.

Thank You again
UncleDoug

good work guys!

Hi UncleDoug,
The way the update services works here is the way I described above, it does sound as if it is behaving differently for you for some reason (Not sure why). :-\