Comodo Dragon ver 18.0 is now available for download

WOO the bug i reported here is finally fixed. it must have been a chromium problem. i can finally start using Dragon again

Explain this…

So far, since I’ve used C D version 16 through 17.5, I have not needed to install any Flash Player in order to watch/play YouTube videos. Will this now be different for version 18.0? So, if we take the update from v17.5 to v18.0, will we need to download and install an extension or something of Flash Player for watching Youtube videos in Comodo Dragon v18.0 ?

Silent install DragonSetup.exe /S not worked - in the disk C: created folder ComodoLogsFolder with file DragonSetup.exe.log: [30.03.2012 04:33:40:643|000855|record] record: RegQueryValueExW failed

Not sure, didn’t test :slight_smile:
Today it seems to be fine so far.

No, you don’t need to download and install Flash Player for watching Youtube video.
This is an option available during manual installation of Dragon.

Dragon is based on Chromium version 18.0.1025.140. Exactly as it is written in About dialog.

Silent installation will fail if either Dragon application or installer is running. Please check that Dragon is not running during silent install. Also please check the installer exit code:

start /wait DragonSetup.exe /S

Are you saying that you have released Dragon v18 based on latest BETA and not latest STABLE Chromium version? ??? :o

:o ??? 88)

Am I stupid or what but you are claiming its both .140 (beta) and .142 (stable) in two different posts ???

your original post still says 140

dragon still puts a shortcut on desktop for auto update

At work here, I decided to upgrade to the beta of Comodo Dragon so I could have the security fixes that were introduced in version 18 of Chrome.

However, when I downloaded it, I noticed the file was 31 KB instead of 27 MB. I opened the file up in a text editor and I saw some HTML from McAfee that contains the following message: ???

Malicious code “McAfeeGW: Artemis!73DF7DB5BDED” has been detected in content originating from Your organization has defined a policy to help protect your computer from infection.

I thought you guys might want to be aware that McAfee, either rightly or wrongly, is flagging your file as malicious. You may want to evaluate whether you do in fact have a virus inside this file, or whether McAfee is detecting a false positive. Either way, this needs to be dealt with. 88)

Really this kind of thing should have been checked with all the major AV vendor’s software before a link was provided to end users. It’s mere professional courtesy.

Hope this helps. :wink:

Yep. Please report this false positive to McAfee.

It’s impossible to determine which part of an applications code any given security product may be objecting to, so expecting releases to be FP free on all security products is something that cannot be expected.

The only people that can fix this FP is McAfee.


We contacted McAfee already, waiting for fix from their side.

Unfortunately detection can be introduced at any moment after download links has been made live.

This release works like a charm !
Many thanks

Yeah that’s a little confusing :slight_smile:

I have a bug with dragon. Every time I start it for the first time i get a message in the top right corner saying something is trying to change my default search engine. This only happens when I start it for the first time. If i close dragon and reopened it the message doesn’t come up. But if i restarted my computer and opened dragon the message comes up. What do you think is causing the problem?

Doesnt sound like a Dragon problem. it sounds like a toolbar or extension is trying to change your search engine

maybe but i never had this problem with any previous version of dragon. The message is “Arrr! something tried to comandeer your default search setting”. I haven’t changed any of my extensions. Just updated to dragon 18 and this started happening.

I have two extensions: Adblock & Do Not Track Plus

weird i have never seen that before. i have ad block plus aswell.
have you installed any toolbars lately? or any new software that might have a toolbar with it.

Hi jgold3591,
To protect against search engine change is a relatively new function to Chromium.
As wasgij6 noted I also suspect a 3 party program has at least attempted to add a tool bar sometime previously.

Also you noted it happens after reboot, do you have some program like CCleaner to clean on boot?
If yes try disabling the cleaners browser cleaning functions on boot (It might be trying to remove your default search engine or cookies belonging to).