Comodo Dragon v80.0.3987.87 is now available for download

Hello All,

We are pleased to announce the release of Comodo Dragon v80.0.3987.87


  • Updated to Chromium v80 codebase

Comodo Dragon v80 64 bit
Comodo Dragon v80.0.3987.87 64-bit can be downloaded from:

md5: 51B9D080410C2E4E481F767EE5FBEE7E
SHA1: 0865CEF045BC4128071B147EE66761F212423E43
SHA-256: 1F7052BEDA641DFBF59B191FF42C957EB64C394CEBFCB7589866BB198B460441

Comodo Dragon v80 32 bit
Comodo Dragon v80.0.3987.87 32-bit can be downloaded from:

md5: B76249821BE428BAD1C8B2501F2A7B8D
SHA1: 3A9C40C00E93C21DF92902B94EA206729311A44D
SHA-256: D48891B8EA93EC2BD4C4541D33178C2643A6655FB284B64CCB57F7268ECE8C58

The update will be pushed out to existing users with then next few hours.

Please use the browser and give us your feedback.

The Comodo Browser Team

Thanks ! Installed this release (64 bits) just now. The very first thing it did was to open a new tab with this ominous warning :

Your web activity is monitored
Any text entered, any page viewed or any activity performed on the web is monitored. The content of the sites can be modified without your knowledge.

This problem is caused by a certificate installed on your device by yourself or by someone else. This certificate is used to monitor and intercept networks, and is not trusted by Comodo Dragon. Although there are legitimate cases of surveillance (on a school or company network, for example), Comodo Dragon wants to make sure that you are aware of this activity, even if you cannot prevent it. Monitoring can occur on any browser or application that accesses the web.

What’s the matter ? It says clearly there is (at least) one potentially “bad” cert installed on my Windows 10 device BUT gives no indication, zero, zilch! of WHICH cert(s) it has thus flagged (maybe wrongly, idnk).

Please help : how ? do I identify the problem in order to, hopefully, solve it IF it is real (I am the owner and “administrator” of this machine).

Hy Czerno
it might be from some 3rd party software you installed on your computer, can you send me a print screen of the error and the link it opened.

Maybe an extension, but the warning is new and I haven’t changed my extensions. Also, the message specifically speaks of an untrusted certificate, without naming one unfortunately.

Capture of the comodo window with the warning tab sent to your (Sergiu’s) kind attention just now.

Installed the 64 bit as an upgrade over the previous version. Rebooted as always and everything running well. No problems at all :-TU

Once again, erased the Comodo logo from the taskbar. Now, it’s only a blank sheet, again. :-TD

what windows version are you using?

I’m still using Windows 7 Ultimate x64.

So it’s only the taskbar icon that is broken?
do you mind doing this fix? sometimes img cache can corrupt

With this version of Comodo Dragon, I can’t read any publications at “”. They just display empty pages with a loading symbol. Try this for example “Golf Vancouver Island - Golf Vacations 2020 by Golf Vancouver Island - Issuu

I’ve made a clean install of Dragon 80.0.3987.87 on another computer, and the problem exists there too. The site works when using a previous version.

Yes, it’s only on the taskbar.

I did the fixing thing but it didn’t fix.

Hello Sixtyfour, thank you for pointing out this issue we will make sure to add this web page to our tests, we are looking for a fix asap, i’m sorry for the inconvenience!

My computer updated to the new version yesterday. Since that time I am no longer able to access anything from the Western Journal. An example link is this:

Any time I click on a link for an article from the Western Journal my browser crashes. All of the links that crash my Dragon browser work fine on Microsoft Edge.


No problem when I click on an article. It opens at once. I don’t know if that could be a reason:

Have a look in blocked aplications in cis.

Hello biga, thank you for helping us by reporting this issue, can u please try to delete the cookies and cached images…acces this link in your browser - chrome://settings/clearBrowserData?search=clear - go to advanced , select time range : All times, select Cookies and Cached images(Only this 2 if you dont want to loose other profile information) like in the picture i’ve sent you bellow and then click on clear data., do you have problems accessing other web pages as well? are you using Comodo Internet Security?

That fixed it. Thanks.


no problem with this new version.
I am using the 32Bits version with the Sandboxie program.

Hi Sergiu90,

I have tried the above, but am still not able to get through to the Device Management section on the Itarian portal ?

I am able to log in and am presented with my Main Dashboard, but when I click on the link to take me to the Device Management section I am presented with a support desk user login screen, but if I use Ice Dragon of FirefoxI get straight through to the correct section.

Are you able to check another Itarian account please to see if the same occurs on that portal?

I do not generally use CD but due to CID being so long between releases I have decided to give CD a try. I also have CIS installed

Many Thanks

Thank’s Huntokar for taking your time to report this issue, due to chromium v80 SameSite changes regarding cookies some issues have arose, we are working on it as we speak.We will inform you when we have a fix for this problem. Thank you!