Comodo Dragon text display issues

I have noticed that the new version of CD seems to have issues when rendering text. I.E., the “E” looks like a “C” specifically if the font size on a web page is smaller. Also the larger bold text looks smudged. Hope I made this problem abundantly clear. I am currently using CD and have no issues with this, however upgrading seems to start this issue. Using Vista X64 OS. Other than that great browser, thank you for your time and attention.

type in dragon://flags in your address bar, and enable “Direct-write” font rendering and see if that helps.

Remember to close and re open dragon to see changes.

I did as you suggested although apprehensive given the dire warnings about altering settings, I enabled direct write restarted and such but it did not solve the issue. Ironically first install of showed improvement but after a second run the text display problem resurfaced. I am using the latest version and still have the difficulties with text I described earlier. It seems that the Yahoo main page is the worst offender, other sites have the text display problems as well but to a slightly less degree. Also running a side by side comparison with CD and Internet Explorer 9 it appears that Internet Explorer does not have the text display problems. So as far as I know this is solely a Comodo Dragon issue. Thanks for the tip and the help though.

Do you have Privdog installed? Try disabling it and see if that improves fonts (If you have the browser extension don’t worry, disable th PD application). I remember reading somewhere that a version of PD was interfering with fonts on some pages.

Also do you have Cleartype enabled?

PrivDog disabled did not improve the situation, restarted the browser after disabling and still the same results. Clear type is enabled and Windows Vista Aero interface is disabled to save horsepower for gaming. OT Aero is pretty but very resource intensive. I will see if enabling Windows Aero will fix the situation, if not I am at a loss. UPDATE, enabled the Aero interface and it did not solve the problem. I am chalking this one up as a bug issue, where the blame lies is open to debate. I don’t know how many people actually use CD but it seems for the time being I am alone in this.

You say your using Windows Vista, please check if you are experiencing the same issue specified here:

Apparently a Microsoft update broke some fonts on Windows Vista.

I give you major kudos for finding this out my friend, it worked! My goodness, I had become complacent regarding Microsoft updates but will maintain vigilance in
the future. To Microsoft’s credit they are very good at releasing updates that do not adversely affect users systems most of the time. My apologies for thinking that this
was a Comodo Dragon issue, clearly I was wrong. Might I suggest to the mods this topic be kept in case of a possibility of someone else having this broken
font Microsoft KB problem and final resolution. Thanks for your kind help and good suggestions Netguy101, i am eternally grateful! I can sEE my fonts again!! :slight_smile:

Glad I could help :slight_smile:

Have a good day, and safe browsing!