Comodo Dragon Prob

A Mod asked me to create specific thread for my prob in offtopic thread so I am mentioning my prob here.

As mentioned in Comodo Dragon 24.1 thread, I am having prob with CD i.e settings are not saved & update download not working manually when autoupdate is disabled in CD settings.

On my system C:\Users<USERNAME> folder is not accessible.

I am in touch with a DEV & he asked me “Make sure that your user has write access on the user profile folder on the system (the C:\Users<USERNAME> folder).”

As C:\Users<USERNAME> folder is not accessible on my system, users here have suggested to take the ownership of the folder. So I requested for screenshot of the ownership of this folder. Few posted the screenshot & it seems that SYSTEM is the default owner of this folder.

I tried to take the ownership as SYSTEM but it give error. How to take ownership as SYSTEM?

Someone posted context menu - take ownership utility but the link mentions this will take ownership as User’s name. I want to take ownership as SYSTEM as it seems the default owner for the folder mentioned as per the screenshots posted by few users.

NOTE - I did tried to take the ownership manually as User’s name & it was successful & the folder opened. This also solved all the CD probs i.e settings were saved & update download manually worked when autoupdate was disabled in CD settings. I then reverted back with system restore coz I want to take ownership as the default i.e SYSTEM.

How to take ownership as the default i.e SYSTEM for the folder C:\Users<USERNAME> folder?

Win 7 64

I have Windows 8 and it works a little differently in the UI aspect so I’ll try to explain as good as I can… =/

What you can do is to take ownership of the folder and once that is done you should be able to change the security properties, correct?

If you are able to change these then you can go into the Security tab, press “Advanced” I think it’s called, after that you go to “Owner” and here you should be able to change the owner to System.

I haven’t tried this but it’s what I would do and I think it should work, if not you could always do a system restore?

Here is what I did…

I opened users folder in C drive.

I right clicked “Home” (Home is my user account name & its an only account on the system & is an admin account) then properties - security (here it was mentioned no permission) so I clicked on advanced - the owner tab - current owner was mentioned as “Unable to display current owner” & below were mentioned 2 accounts, administrator & Home, & there was edit button, I clicked on edit then clicked on other groups… then entered SYSTEM & pressed check & it found SYSTEM, I selected SYSTEM & replace subdir… & clicked apply & ok but it gives error no permission.

The same thing I did but selected user’s name instead of SYSTEM & it was successful.

I dont know why when selected SYSTEM it gives error.

When having access to the folder as user, could you go into the security tab, click edit and add permissions to System?

Currently I am not on that system, later I will check & post the screenshots.

I didn’t checked if I could add permission to SYSTEM & I didn’t add permissions to user’s name too coz taking the ownership as mentioned above the folder & the subfolders were opening fine.

One thing I dont understand is…

I googled a lot & every troubleshoot mentions take ownership & add permissions

After taking ownership, when you right click the folder, the security tab shows few accounts & also the account i.e user’s name which you gave the ownership. Now if you click or highlight this account, below you can see the allow & deny section, & on allow everything is selected except special permission, so why you need to add permissions after taking ownership? Doesn’t on allow section everything selected means permissions is there or I am missing something here?

I’m not entirely sure what you mean but I don’t know how the take ownership actually works. What I imagine is that it makes your account the owner of the file and also gives you permissions for these, but my thought is that it doesn’t necessarily mean the “SYSTEM” has permissions hence if you try to set it as owner but it doesn’t have permissions to that folder, then it won’t allow it. So you have to first add yourself to the permissions then add system to the permissions and then change system to be the owner.

At least that is how I understand it, I might be completely wrong. But hey you’ve created a system restore point, right? So then it’s just to start trying things until something works or something goes horribly wrong and in the later scenario you can use the restore point to fix it.

Naren, the following suggestion requires caution to be used.
Please only follow the suggestion at your own risk.

If you decide to proceed please follow the instructions carefully.
With the trouble you appear to be having with your ‘Windows User Account’, I would consider creating a new User Account and removing the old when you are sure you have retrieved everything you need from it.

Create User Account Microsoft Instructions
Create User Account Windows Seven Forum
Delete User Account Window Seven Forum

Taking the ownership as SYSTEM gives error.

Owner tab shows 2 accounts
Administrators (Home-PC\Administrators)
Home (Home-PC\Home)

Home-PC is my system name & Home is my account name (administrator)

If I take ownership with any of the above then later I am able to change the ownership to SYSTEM.

So what you suggest? Which account of the 2 mentioned above should I use to take ownership first & later change the ownership to SYSTEM?

naren see this -

Add this to the context menu and it will take ownership of which account your currently under.

Hope it helps.

Okay so if it works… then what is the problem now again? =S

The account you use on a daily basis I would say.
On my PC, by default, the folder “Sanya” which is my username, has all privileges for both System, Administrator and my User account. So I don’t see why it would matter which one you use to take ownership if you’re going to give permissions to all of them and then make System the owner?

Now this is confusing or dont know what to say but solved CD prob here.

Created system restore point

I took the ownership as user’s name & the folder became accessible.

I installed CD & changed the settings & the prob was not there.

I restored the system back to the point I created

The folder became unaccessible as was previously

I installed CD & the probs are not there & the strange thing is changed CD settings before system restore are still there.

But in the user data folder of CD there are lots of .tmp files, is it normal?

The bold above you mean when you go to properties - security of the folder Sanya you can see admin, system & Sanya with full rights, right?

When I take ownership as user’s name then properties - security of the folder shows only user account

See attached image.

  1. Click Edit
  2. Click “Add.”
  3. Enter “Administrator” in the same language that the OS was installed in from the beginning, mine was Swedish hence it’s called “Administratör” After that use a semi-colon “;” and enter “system”, then a semi-colon and the username which you said was “home”.
    3.5. Click check names and see if they all are accepted, if not, try checking the spelling and redo it
    3.6. Click OK
  4. Add to the allow section for each of the accounts.
    4.5. Click OK
  5. Click Advanced.
    -Here is where Windows 8 differs from Windows 7, but what you want to do is make System the Owner, if that is what your goal is-

[attachment deleted by admin]

Thanxx for the screenshots. I will try this & post the results here.

But the thing here is quite confusing i.e…

I took the ownership as User’s name & the security tab showed only User Account i.e Home Account

I restored back & tried again taking ownership as User’s name & this time security tab showed Home Account, Administrators Account, SYSTEM, Everyone & one was named as Users Account.

I restored back & tried again taking the ownership as User’s name & this time again security tab showed only User Account i.e Home Account.

Quite confusing here.

But I will try the steps you have mentioned in the screenshots & see what happens.

OK, I did what you have mentioned but now lock icon appears on few files & folders, though all are opening.

If I take the ownership as Administrators (DEV also suggested this) then lock icon doesn’t appears on files & folders & all opens fine but security tab shows only Administrators account, would this be fine with no other probs if I keep this way?

If it works for you, as in things are updating and you can read and write then yes it should be fine. And if any problems would arise then you know where you can ask for help! =)

I have asked this same thing to DEV.

By the way I hope you read my previous post where I mentioned taking ownerhship with different results, tried 3 times, thats really confusing.

And I have partitioned the drive into C & E, E has personal things & C is system drive.

I can reinstall or repair OS without affecting E drive, right? How safe is this? I dont have external drive for backup.

I did read that part but I don’t have any idea why it would give different results hence I didn’t comment on that. =/

I personally don’t know how partitioning works since I haven’t really tried it myself but I’d imagine that a repair would work fine. However a re-install would probably require that none of the system files are located at the E drive but other than that it should work fine I think. Basically C and E are like two different drives now except the information is stored on the same drive, so I think it would work fine as long as you re-install Windows to C drive and not the E drive.
However if you have a hard-disk failure then both C and E will be affected. If you have important files then I suggest you do back ups, there are free services like SkyDrive and DropBoX that give you a few gigabytes of storage, however there is also a new one called which is created by the one and only Kim Dotcom and it offers 50GB of storage for free with encryption. Of course there are more services but I don’t know any other in my head.
You might want to invest in physical back-up too if you have things that you really can not loose under any circumstances. Myself I back-up my school stuff to both Skydrive, dropbox, mega and my thumb-drive.

With trial & error I managed to get it.

First took the ownership as Administrators without selecting replace subfolders/files & clicked ok on all windows.

Then properties - security - showed quite a few accounts. Removed all the accounts except Administrators, Home & SYSTEM.

Then took the ownership as Administrators & selected replace subfolders/files & clicked ok on all windows then add permissions.

Then took the ownership as Home & selected replace subfolders/files & clicked ok on all windows then add permissions.

Then took the ownership as SYSTEM & selected replace subfolders/files & clicked ok on all windows then no need to add permissions as permissions are already there.

Now everything is fine with user account folder & comodo dragon.