Comodo Dragon not remembering any settings.

I don’t know what the problem is, but Comodo Dragon is NOT remembering ANY settings. I am running latest version of I am running Comodo Internet Security version 6.0.260739.2674 database version 14665. Also Windows 7 32bit, all updates current. It seems to have started after 23.4 update. I have tried uninstalling and reinstalling twice to no avail. The uninstalls were complete with no registry or temp file traces left behind. When I make my changes and choose OK, and close out of CD, and reopen it goes back to default…everything. Even the window size goes back to like when I first installed CD. Any help would be appreciated. I have tried searching for previous version of 23.3, but couldn’t find it. Thanks in advance. Merry Christmas!

Hi and welcome mtw75,
You could try installing the portable version, this could determine whether or not it is some form of corruption in you Dragon user profile.
Note: The portable version will not interfere with your installed version, they can be installed together.
How to create a new user profile

V23.3 was short lived due to an issue, but V23.2 can be downloaded at the following location.
Dragon Filehippo

All the best.

OK, I tried installing the portable version and it is doing the same thing - not remembering settings after closing and reopening. Now I must add that while waiting on a response to this thread, I completely uninstalled anything to do with Comodo (Comodo Internet Security, Dragon, IceDragon). I’m certain no traces were left afterwards. I then reinstalled the latest Comodo Internet Security and selected the option to install Dragon during installation and I noticed that it created a “Virtual Dragon” shortcut on my desktop which leads me to believe that Dragon is somehow being sandboxed or fully virtualized and after I close it down, it’s deleting all my settings in the process. I have searched extensively through CIS’s new UI, but cannot see anything where I can remove Dragon from being sandboxed or fully virtualized. I’ve looked in the Defense+ settings, HIPS, and Sandbox settings and I don’t see it. Could it be possible that it’s unchangeable due to the fact that Dragon is required to be installed with the new version of Comodo Internet Security? At least if you want to use the Virtual Kiosk. Oh and CIS version is: 6.0.260739.2674 Thanks again for any help/suggestions.

Hi mtw75,
You should of had two shortcuts created one virtualized and one not.
If it is running virtualized every time the settings should stick until you reset the sandbox.
Also if it is running virtualized it would have a green border if set to do so in the Defence+ sandbox settings.

If you only have a virtual shortcut go to Windows Start Menu, All programs, Comodo, Dragon, Comodo Dragon and run it from there (Non virtual) or create a standard shortcut from there.

Thanks for the reply. I have tried everything you suggested and still the problem persists. The green border is not around Dragon so I guess it’s not virtualized. I don’t know what else to do besides use IceDragon exclusively. Thanks.

Hi mtw75,
Sorry this problem is persistent.
Do you use Google sync at all?
I will ask the other Mods to take a look at this topic, they will only reply if they have any other ideas.
Thanks for your patience.

No, I do not use Google sync. This might seem drastic, but this is bothering me so much that I’m going to do a fresh install of Windows and see if that corrects it. If not, that means it’s definately a bug in CIS new version and/or Dragon version itself. I will update my outcome. Thanks.

Well, I finally got around to redoing a fresh install of Windows and CIS and Dragon. Everything is fine now. I think I might have inadvertently messed with some settings when I was navigating through CIS new UI. Before when I opened Dragon the new Widget Status Pane showed 3 applications running in the sandbox. If I remember correctly they were 2 svchost.exe and 1 cmdvirth.exe. I opened KillSwitch to see if they had anything to do with Dragon, but they didn’t. I didn’t pay that any mind until after the fresh install because the Status Pane is no longer showing anything sandboxed even after opening and closing Dragon. So perhaps those 3 “unknown” sandboxed applications was my problem in some way. Anyway, thanks for your replies and suggestions.

Hi mtw75,
Unfortunate that you required so much time to correct what initially appeared to be a small problem.
I guess the main thing that matters is that it is working correctly now. :-TU
Hope it continues to behave and all the best to you.

I’m writing because my Comodo Killswitch is showing CMDVIRTH.EXE and two SVCHOST.EXEs running sandboxed, just like MTW75 noted in one of his posts on 2012-12-26. However, unlike MTW75 I’ve never used Dragon; I use Firefox. And I haven’t observed any failures by Comodo to remember settings.

Those three processes showed up in the sandbox once before and they stayed until I restarted my computer. (Vista 32 Home Premium.) Now they’ve reappeared in the sandbox.

Last week I installed Comodo CIS on my brother’s computer (also Vista 32 Home Premium) and at one point noticed those same three processes in his sandbox. At the time, very few apps were running on his computer, and normally those apps run without any processes in the sandbox.

It seems very strange that Comodo would sandbox one of its own files (cmdvirth.exe). According to KillSwitch its rating is “Unknown,” which also seems strange. (The rating of the two svchost processes is “Trusted.”) Earlier today I tried twice to submit cmdvirth.exe to Comodo using KillSwitch’s right-click “Send to Comodo” | “Report as Suspicious” but the submission result was Fail; I tried again a minute ago and this time it reported Success. (The other submit option, “Report as False Positive,” is grayed in the menu and unavailable.)

There have been a couple of times when Killswitch’s icon stuck in the Windows tray even after I had exited Killswitch. Right-clicking the icon did nothing. Its tooltip popped up if I hovered the mouse on the icon but the cpu% info in the tooltip was the same every time I raised the tooltip, which I assume means the cpu% was not being updated. Windows Task Manager listed KillSwitch as a running process. In that situation, Comodo’s gadget was unable to launch Killswitch until after I terminated KillSwitch using Windows Task Manager.

I’m a new user of Comodo. I installed Comodo Antivirus (with Defense+) about a week ago but I did not install Comodo’s firewall because I’m still running ZoneAlarm Free Firewall. (I plan to replace ZA firewall but I haven’t yet reached a conclusion about what to replace it with. Perhaps Comodo firewall. Perhaps PrivateFirewall.) On my brother’s computer, however, I installed all of CIS (after uninstalling Verizon security suite, which Verizon licenses from McAfee, I think). My brother’s computer has never had ZoneAlarm.

Is it a bug in Defense+ that causes it not to trust cmdvirth.exe? On my brother’s computer, I think I kept Comodo set with its default settings (because my brother isn’t sophisticated about computers).

Thanks in advance for your assistance!