Comodo Dragon Installer Popup - How to remove?


I installed CIS on a brand new Windows Home 7(64) reinstall on a laptop. I used advanced install and DESELECTED everything except the firewall and AV. That was all good, and after doing the updates I checked and no, it has not installed privdog(like some others have had).

BUT, I keep getting a nag “windows installer” popup asking me to install Comodo Dragon. I say no(to allowing it to install on my computer) and it goes away.

For about 2 minutes, then it is back again, how do I stop this, I don’t want another browser, I have 4 already, if it was any good, let it go out there and maybe over time I may give it a try, but don’t FORCE it on me if I don’t want it.

Please help me get rid of this. I have tried via Task Manager, but even it fails to end the process, it is locked by CIS.

Thanks in advance

Did you reboot after installation?

But of course, quite a few times now and it is still there on my task bar as a pulsing icon then it will pop up after a few minutes of inactivity by me :frowning:

can you take a screenshot of the icon that your referring to?

Sure, I could not take a screen shot because it drops out of windows, goes dark, and into installer mode, but took a photo on my iphone, and transferred that to my desktop, but there is nowhere here to upload it to here?

Lets try this

Of course I click on NO and it goes away like I said for a minute or so. If I click on the "change when to notify me’ it is just the standard windows slider bar under user account control settings, nothing in there that says forget this product

edit OK I did a screen shot of the task manager, both with the nag and without, the only difference is a program called dragon_setup.exe The issue with this is that if I do a search on my computer for this, the result is blank, so it is a hidden file inside Comodo somewhere

*2nd edit Ok I found it in C:windows/temp/ But I could not delete it as it was being used by Comodo. I rebooted into safe mode with networking and deleted that file, no problems there, but sadly, when I booted back into windows normally, blimmin comodo had resurrected it :frowning: Insidious and not user friendly :frowning:

Hi TravellingStrom,
Using caution and to be done at your own risk as this involves editing windows registry.

Check windows registry in the following locations for any reference to dragon_setup.exe.
If found, right click the dragon entry name and delete.
Most likely found under ‘runonce’.

Kind regards.

I checked all 4 locations and the only entry besides default, was one for CIS itself, so I need another solution please.

Just for the record, while waiting for a response, I decided to say YES to the option in the pix above. This then launched a Dragon installer, as expected and here once again, I was given the option to agree to the EULA and install, or cancel the install. I clicked on cancel th einstall, but I am still getting the nag screen!!! :frowning: >:(

Hi TravellingStrom,
What does the entry contain, is it cistray.exe or is it a setup entry?



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run cistray.exe

Sorry TravellingStrom, I am at a loss as to why this is happening.
It looks like some type of unknown corruption occurred during installation.
I guess the next step I would try would be to uninstall CIS and make sure the problem has gone, then try a clean re-install.
Sorry I don’t know what else to suggest.
Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems

Kind regards.

Hmmm, I guess I have no choice. I will follow that link you gave and do that and install it again. If it still has issues, it get sthe boot and back to NOD32 and windows firewall

Comodo seriously needs to look at their installer system, I see many faults on this forum that would not happen with a working unit.

Anyway, thanks for your help, we shall see what happens.


captainsticks, hi.

I followed the uninstall instructions to the letter and it all looked good. I then disconnected from the internet and installed the latest installer, all 220Mb of it, massive!! I allowed the cloud thing and to send anon info about unknowns etc, but unchecked, privdog, dragon and the other thing, cannot remember, but only installed AV and FW

It then installed and wanted to do a scan, which it would not do as it wanted to check for updates first. I left it suffer for a while, no internet, and I saw nothing untoward.

So, I re-connected the internet and clicked on update. There it was, while downloading the new signatures, up pops a windows installer message from bloody Comodo Dragon, it comes WITH the updates. So this program is the actual problem and I will now have to find a way of getting rid of this because, seriously, if I say I do not want something, that really means I do not want it!!

I will let Comodo have a week to sort this out, and I am being generous, then out it goes never to be used by me EVER again, and that also means many referrals!


Can look at it for information.

Hi TravellingStrom,
I believe you have hit something really unique here, I have been around Comodo for awhile now and have never seen this happen before.
That is why I was working on it being something corrupt with installation, but unfortunately nothing solved the issue.
With the uniqueness of this issue it would be unfair to solely condemn CIS IMO.
If you would care to take the time to create a bug report for this in the hope the Developers can reproduce or rectify the issue, it would be greatly appreciated.
Whether or not you create a bug report is obviously your choice.
Once again I am sorry this issue persisted, even after a re-install and it would be nice for us all to know the cause.
Bug Reports - CIS
Required Format For Reporting Bugs

I thank you for your patience with this issue so far.

Kind regards from Captainsticks.

Download Autoruns and look up the autorun entry of Comodo Dragon installer and disable it. That should do the trick.


Since you asked so nicely I will give it a go for a bug report, if I can sort it out.

It is good(or extremely bad) to know I have a unique fault, just what I need, not!

Thanks for your help


Hi TravellingStrom,
Thank you, your time and effort is greatly appreciated. :-TU
Chiron does a fine job at helping fine tune bug reports to pass on to the Developers. :-TU

It is good(or extremely bad) to know I have a unique fault, just what I need, not!
Good for other users I guess, not so good for you. Not to say it will stay unique to your system, we never know what the future may bring. :)
Thanks for your help


You are welcome, thanks from Captainsticks.


I did not see this post until today, not sure why.

Anyway, I will see what I can do. I use a program called Your Uninstaller, which controls all my programs and start menu stuff etc. Once the standard program uninstalls itself, this goes in behind and cleans up all traces, it does a good job. There are no Dragon entries that I can see. I notice though if I have task manager open, nothing shows until the nag screen pops up, it must be being called by the update program.

If the program is free and not restricted, I will try this autoruns and see what happens, before I go through the whole process of CIS removal and install again


Blimmim marvelous tell ya Ma :slight_smile:

Yep, did that and it has now gone and survived two restarts so far. I guess the telling question will be after the next large update.

Thanks for the tip, problem solved