comodo Dragon installation problem

I downloaded the comodo Dragon installer and when installing get the message “Comodo Dragon has encountered a problem and needs to close. We are sorry for the inconvenience”.(unspecified problem) . I want to try Dragon since chrome is no longer supported and I like the chrome style interface

Please advise.

Margaret Stanley

This may be relevant.

When I start up google chrome I get the message :
"This computer will no longer receive Google Chrome updates because its hardware is no longer supported . "
Windows XP Professional 32-bit SP3

CPU purchased new in 2004.AMD Athlon XP Family 6 Model 10
Barton 0.13um Technology
RAM 1.00GB DDR @ 166MHz (2.5-3-3-7)
MotherboardMICRO-STAR INTERNATIONAL CO., LTD MS-6734 (Socket A) 56 °C
Graphics Standard Monitor (1024x768@1Hz)
Storage 74GB Seagate ST380011A (ATA) 35 °C

Considering this is a Comodo Dragon question, it should be posted in:
https://forums.comodo.com/help-cd-b206.0/

But to reply to mandywr’s question, since the current Comodo Dragon is based on Chromium 36 codebase, ever since Chromium 35 the codebase requires Pentium 4 CPU’s or newer with SSE2 instructions to run.

Your AMD Athlon XP does not support SSE2 so Google Chrome will no longer update on your computer, and latest Comodo Dragon will not run on your computer neither.

Moved.

Try the old version Comodo Dragon 33
Downloads

Or

All versions of Comodo Dragon