Comodo Dragon do not open https:// url

Hi
I have on my Windows computer Firefox and Iron web browsers.
I have installed Comodo Dragon. Unfortunately there is bug that I don’t understand how to fix.
If a try to open https link like page of the bank or mail service or google services over https, it dosn’t work. After a minute gives “page is not available”. At the same moment I try with Iron (other chromium based browser) and everything is fine.
I have tried different Dragon setings and it doesn’t matter. I fought it have something to do w DNS or certificates. I check ComodoDNS and OpenDNS and it doesn’t matter.
As I said at the same moment Firefox and Iron work fine.
Also problem doesn’t involve normal http pages.
What’s wrong?

Hi and welcome Namche,
Try disabling ‘Do not allow websites to know where you came from (suppress HTTP referrer header)’ found under privacy in the advanced settings.

Kind regards.

I have done that.
Result is that it open first 4 https page and it that stops opening next pages.
I got 60Mb/s connection, so it’s not bandwidth.

Sorry that didn’t help, at this stage I am not sure what else to suggest (Still thinking).
Let us hope someone else has some ideas.

After some time I have tried to reload those https “unavailable” pages and it didn’t help.
Sometimes it load one https page, but 95% of time it doesn’t.
It makes it more interesting because it loaded them. If it doesn’t load a page there is no way it will load other. But sometimes one, mayby two https pages it load. Only fresh after restart of the browser.
Strange.

I have uninstalled Dragon and then installed it once again.
Unfortunately it didn’t help.

I have changed User Agent. I help at first for few https but that it once again block reliable bank https pages.

Hi Namche,
I realise you have said that you have tried various DNS settings, but have you disabled ‘malware domain filtering (Comodo Secure DNS)’ within Dragon?
Found under privacy in the advanced settings.

Also it might be worth trying with the ‘PrivDog’ extension disabled, or add the malfunctioning sites to PrivDogs exception list.

Yes I tried with Comodo DNS enabled and disabled.
I have uninstalled PrivDog.

I think the problem lies in the processing of personal certificate by the browser and making a secure connection. Unfortunately, I do not know how it can be repaired.

Hi Namche,
Sorry my suggestions have failed.
I will have PMed a Staff member to see if they can assist with any ideas.
Please note: Staff will only reply when/if time permits.

Thanks for your time and patience.

Hello,

Please check if your firewall software allows Dragon to connect through port 443 (the default port for https).
Also add a complete bug report by following these instructions: https://forums.comodo.com/bug-reports-cd/how-to-submit-bug-reports-read-this-if-you-want-them-fixed-t58007.0.html.

I’m interested first in knowing what security software you have installed on your system, firewall settings (especially if you have set any custom rules), network monitoring software and extensions that you have installed in Dragon. A list of example pages might also help us identify the issue.

Thank you.