Comodo Dragon Defaulting To Comodo Home Page

Not happy. That same homepage problem is happening - set it to “New Tab Page” which is exactly the Chrome/Chromium/Dragon default behavior I want and have had since forever - and I get

I’m highly technical. I can jump through all the hoops listed above to restore it.

I’m not going to. Instead I’m uninstalling Comodo Dragon from all machines, withdrawing and publicly renouncing my longstanding support of Comodo on FB and G+, and don’t trust Comodo anymore.

This is not a bug. It’s clearly deliberate, forced advertising. It’s the same mindset as a few releases ago where Comodo took out the ability to change themes. Yes, Melih piped up with “I think users should be able to change themes”, and the feature came back in 18 or 18.1.

But clearly, Comodo’s strategy with Dragon is not to add value or functionality to Chromium compared to Googlized Chrome, it is to push the Comodo branding.

I find that more obnoxious than using a browser “from an advertising company”, so I’m going back to Google Chrome.

It also generalizes, making me distrust Comodo as an Internet Security Company, its core mission. When a software maker hides, hijacks, disables user control of built-in functionality, what else is it doing? What else will it do? Given that all Comodo products are Closed Source, we have no way of knowing. Sure, many of them are Free-as-in-■■■■, but none of them are Free-as-in-Freedom. Until now, I have trusted Comodo. Now, after two in-your-face functionality disablements within their so-called more-secure browser, I don’t.

These may be minor incidents, but they are symptomatic of Comodo “Being Evil” - at least more so than even the “advertising company” Google who doesn’t always live up to their “Don’t be Evil” motto.


Wow, someone needs a hug. >:-D Yea, I hear what you’re saying. Have you tried SRWare Iron yet?

Have you set Dragon’s homepage to something other than default ?

First of all I would like to thank you for alerting Comodo to this problem. I’m sure Comodo will look into this and change the default behavior for the home page. I’d also like to add that I’m not a very big fan of this type of behavior either.

That said I’m sure that you will agree with me when I say that the way that you phrased your complaint was definitely inappropriate. It’s not fair to say that Comodo hijacked anything or reduced user-control. Every user still has the ability to change the home page to whatever they would like. Comodo just made it so that the default home page was the Comodo main page. Whether you like that or not you have to admit that this sort of behavior does not constitute grounds for making claims such as that Comodo is

"Being Evil" - at least more so than even the "advertising company" Google who doesn't always live up to their "Don't be Evil" motto.
Also, I'd like to point out that this sort of comment is the type which, especially on the Comodo forum, would be likely to stir up arguments. It's largely for these sort of reasons that this topic was temporarily removed from the main portions of the forum while it was under review.

In conclusion, I appreciate your concerns and truly hope that the default home page will be changed in the next version. However, please show respect for the forum and those who read it by remembering that your topics will gain much greater positive attention if they are phrased in a much more respectful manner.

Thank you.

I also face this problem for a while. Initially I thought this was a bug in the portable version of Dragon but it also appears in the normally installed Dragon. I want to have the last set of tabs opened and not the Comodo home page.

I don’t understand from the previous post if this is indeed intended behaviour or a bug. Should it be intended behaviour (as advertising) this would be an immediate reason to say goodbye to Dragon.

Can anyone shed a light on this?

Hi weaker,
A bug or intentional will be forever debated IMO.
A simple workaround posted by user Jon79 in the quote below.
Kind regards.

I don’t think there is anything sinister going on. Comodo does not know what home page you would like to start with until you tell it.

Mozilla Firefox defaults to a Mozilla page unless you choose something different. Chrome defaults to Google. And the 2 Comodo browsers, Dragon and IceDragon, default to Comodo.

But it takes only a minute or two to change that to your preferred start page.

can you pls give us more technical details about what behavior change caused the problem for you so that we can get to the bottom of it.

It is not our intention to force our brand on users.


That workaround does not help if I want the set of last tabs to reopen on startup.

Good to hear that and from Comodo’s reputation I hoped that this would be the answer.

There was no behaviour change: I installed CD on Win7-64bit-SP1 first as portable application. When I noticed the behaviour of not remembering the last tabs, I installed the non-portable version. But this didn’t help either. So it didn’t work for me right from the start. I never had these issues on another machine with WinXP (non-portable CD).

Best regards

Hi weaker,
I am not sure I am following here, that workaround works exactly as I would expect Open a new tab page to work on my system (The original issue).

If you want the last tabs open to re-open you would have to set Continue where I left off, which also works on my system.

i have the same issue as weaker.
CD settings is set to Continue where I left off, but it’s still open default page by turns
my systems:
PC. win7 32 ultimate sp1. logged in as user
notebook. win7 32 professional sp1. logged in as local administrator
ps: sorry me my poor english


This issue is fixed in Comodo Dragon

Please provide the following information so we can investigate the issue:

  • The Comodo Dragon version that you are using.
  • A list of the extensions that you have installed in Dragon.
  • Whether Dragon is installed as portable or non-portable.
  • Install location.
  • Whether you are running Dragon in incognito (“Start browser in incognito mode” is checked in settings).
  • The page that is set as home page (check the “Open specific page or set of pages”).
  • The page that is loaded when launching Comodo Dragon.
  • Whether you are running Comodo Dragon in a sandbox.

Thank you.


thank you.

ps: i’am continuously using application shortcuts for some flash based sites… if it recks…

added 12/11/01
i’m confident it’s due to using regular browser window & application shortcuts. worse luck still can’t get system…