Comodo Dragon and Ice Dragon Cannot Save Or Upload Files To Sites [M955]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Start Comodo Dragon as sandboxed FV. I have tried running Dragon Virtualised using the ‘Switch to Virtual mode’ in the Comodo Dragon menu, manually running CD using the Sandbox menu in Comodo Firewall after resetting the sandbox, and inside the Virtual Desktop. The effect is the same for all.
    2:I cannot save or upload any files to any site (when I click ‘choose file’ in Comodo forum attachment, the browser just blinks and I don’t see my folders, when I right click and select save on images, nothing happens).
  • If not obvious, what U expected to happen:
    Comodo should be able to upload and save images.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
    Comodo Dragon 31.1.0
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    This started happening after the last update. The previous version was working fine.
    I tried disabling extensions, resetting the browser and sandbox, and uninstalling and reinstalling Comodo Firewall. None of this helped.
    A full dump, made using KillSwitch when Ice Dragon was running virtualized, can be downloaded from here:
    Here is the same for Comodo Dragon
    Also, note that the green border is missing and Adobe Flash Player(Latest version) plugin fails to load randomly in websites with flash content.

[ol]- Exact CIS version & configuration:
Comodo Firewall 7.0.315459.4132

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default settings.
  • Have U made any other changes to the default config? (egs here.):
    Defense + safe mode; BB disabled; Firewall safe mode; Av not installed;
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Win 8.1 Pro 64bit with all updates
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=Zemana, Malwarebytes AntiExploit, Avast Free b=None

[attachment deleted by admin]

Please try reinstalling CIS by following the advice I give in this post and see if the problem continues after that. Very often just unintalling and reinstalling, without running the removal tool, is not sufficient to fix issues such as this.

Let me know how it goes.


I can confirm the lack of a green border on Dragon when sandboxed in the latest version of CIS.

I can also confirm the “Shockwave Flash failed to load” message when running Dragon in the sandbox.

I have not tried the “choose file” problem reported.

CIS 7.0.315459.4132, Windows 8.1 Pro 64-bit, plus all latest updates

I formatted my pc as well. Same persistent problem.

Does this happen for other browsers when they are sandboxed, or is it specific to Comodo Dragon?

I can see the green border when I run Firefox sandboxed, but while playing flash content Firefox freezes. I guess yes, it happens with all browsers.

For only information.
All browsers work for me in Sandbox.
IE 10, CID poortable, СD portable, FF portable.
There are green borders.
Only doesn’t work FF portable.
Even FW doesn’t give requests for connections FF. (it only in Sandbox
But: Win7 32 SP1.
I don’t create the report, there is a check.

Edit: I found a problem with FF.
Not correct badge (label).

There is another in the App\Firefox folder
From it everything works.
But begins with pure Firefox. (without additions, bookmarks, etc.)
Excuse for that to created a Reply.

christarzan, please create and attach a diagnostics report to your first post.

Also, start dragon sandboxed. Then open KillSwitch, right-click on any process, and choose to make a Full Dump. Then upload that to a file-sharing site, such as this one, and paste the download link in your first post.

Finally, please edit your first post so that it is in the format provided here.

If you need any help with anything please feel free to ask.



Thanks. However, your first post was not quite in the correct format. I have put it in that format, and tried to move information around accordingly. However, it’s possible I’ve made a mistake. Please look it over and make sure that everything looks correct.

For future reference, to use the format you can just copy and paste the code. Then replace the question marks with your responses.

Let me know if you have any questions.


Thanks for your help :slight_smile: Yes, this report is fine :azn:

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I have been informed that apparently it would be best if a separate bug report were created for each of the three problems. Therefore, let’s make this one specifically about the green border issue. I will modify it myself accordingly once you respond. However, I also need to know how is Dragon being run? Is it being run from the widget, inside the Virtual Desktop, by right-clicking to run sandboxed, or from manually adding it to always be sandboxed?

I’ll send you a PM with the code from this report. That way you can just paste it in your two new topics and change a few things around.


Thanks again. Yes I will create two reports.

If I run Dragon Virtualised using the ‘Switch to Virtual mode’ in the Comodo Dragon menu and if I manually run CD using the Sandbox menu in Comodo Firewall after resetting the sandbox, the effect is the same. I have noticed the same inside the Virtual Desktop.

Thanks. I have edited your first post. Please look it over and let me know if everything seems fine.

Also, is this problem specific to Comodo Dragon? If not, please list all browsers on your system which it happens for.


Please let me know if this is specific to Comodo Dragon? If I don’t know that I cannot re-open this in the tracker. Also, if it does not happen with Ice Dragon I will need a Full Dump created while CD is run as FV.


Yes with both Comodo Dragon and Ice Dragon

For Comodo Dragon

For Ice Dragon

Thank you. I have now updated the first post and updated the tracker.

Thanks again.

Not fixed in new version

Thank you for checking this. I have updated the tracker.