Comodo doesn't detect adware

I am using Zorin OS 9 (Ubuntu 14.04), and last week, my Google Chrome started randomly loading up shopping sites on top of the tab that I was viewing. I could click the back button to return to the previous page. Luckily, I have the ScriptSafe extension, so the pop-ups don’t run scripts. displayed a few times, so I did a search on that. However, I’m having trouble finding out how to remove it from Linux, and where it is located in the file system. I used Comodo to do a complete scan and it tells me that I have zero threats. Meanwhile, I have blocked in my router, but other sites pop up that I suspect are affiliates, like

Have you tried looking in Chrome Tools/Extensions to see if anything you didn’t put there is installed?
Failing that you could try Chrome reset - Settings/Advanced/Reset.

Yes, I checked my extensions. After all this frustration, I researched how to remove Google Chrome on Ubuntu and first I used Synaptic Package Manager to uninstall, but it did not seem to actually work, then, did this in the terminal:

sudo apt-get purge google-chrome-stable
sudo rm ~/.config/google-chrome/ -rf

I manually deleted etc/apt/sources.d/google.list

I had already stopped the sync to my Google Dashboard profile, and had done the Reset on that page to remove all extensions data, etc., from their servers. Then after shutdown and startup of my computer, I did a new install of Google Chrome. The problem reappeared - popups, but it happens rarely, so for the first 2 days I thought I cleaned it. I do not visit risky sites. I did previously let a guest use my computer during Christmas break.

It does not seem to affect my Firefox browser, but it’s such rare symptom, I don’t know for sure.

Ugh, I just discovered that my CAVL had stopped running in the green, and I have to troubleshoot that again, as I had thought it was fixed days ago when I found the Chrome problem- redirts.ko module does not exist. Something is deleting it, perhaps?

I don’t use chrome, but I strongly suspect it will also have a hidden cache in your home folder which you should probably also remove. Probably at ~/.cache/google-chrome.
apt actions don’t as I understand it affect application data stored in the home folder, only the system folders.

I decided to give up on troubleshooting, and erased my hard drive. I installed Ubuntu 16.04 and I can’t get Comodo running at all - shield stays red, and I tried all the steps provided by Kintu-Japan. So, uninstalling Comodo, and going with Sophos. I am not happy about that, I have loved Comodo for a decade, starting when I was using Windows.

I gave up on Comodo too a long time ago and have been running Sophos since. In the only tests I have seen reported it has far better detection anyway.